Welch Allyn Connex® VM data
management system

Administrator guide

© 2012 Welch Allyn. All rights are reserved. To support the intended use of the product described in this publication,
the purchaser of the product is permitted to copy this publication, for internal distribution only, from the media
provided by Welch Allyn. No other use, reproduction, or distribution of this publication, or any part of it, is permitted
without written permission from Welch Allyn. Welch Allyn assumes no responsibility for any injury to anyone, or for
any illegal or improper use of the product, that may result from failure to use this product in accordance with the
instructions, cautions, warnings, or statement of intended use published in this manual.
Welch Allyn, Connex, and Spot Vital Signs are registered trademarks of Welch Allyn. Microsoft, Windows, and SQL
Server are registered trademarks of Microsoft Corporation. Citrix and ICA are registered trademarks of Citrix
Systems, Inc. XenApp is a trademark of Citrix Systems, Inc.
Software in this product is Copyright 2012 Welch Allyn or its vendors. All rights are reserved. The software is
protected by United States of America copyright laws and international treaty provisions applicable worldwide.
Under such laws, the licensee is entitled to use the licensed software as intended in its directions for use. The
software may not be copied, decompiled, reverse-engineered, disassembled, or otherwise reduced to humanperceivable form. This is not a sale of the software or any copy of the software; all right, title, and ownership of the
software remain with Welch Allyn or its vendors.
Federal law restricts this device to sale by or on the order of a physician.
For information about any Welch Allyn product, call Welch Allyn Technical Support:
USA +1 800 535 6663
+1 315 685 4560
Canada +1 800 561 8797
European Call Center +353 46 90 67790
Germany +49 695 098 5132
Latin America +1 305 669 9003
Singapore +65 6419 8100
United Kingdom +44 207 365 6780

Australia +61 2 9638 3000
China
France
Japan
Netherlands
South Africa
Sweden

+86 21 6327 9631
+33 155 69 58 49
+81 42 703 6084
+31 202 061 360
+27 11 777 7555
+46 85 853 6551

DIR 80015957 Ver. G
Connex VM 2.0 Administrator Guide

Welch Allyn, Inc.
4341 State Street Road
Skaneateles Falls, NY 13153-0220
USA
www.welchallyn.com

Regulatory Affairs Representative
Welch Allyn Limited
Navan Business Park
Dublin Road
Navan, County Meath
Republic of Ireland

iii

Contents
About this guide ...................................................................................... 1
Safety symbols .................................................................................................................................. 1

Reference documents ............................................................................. 3
Introduction ............................................................................................. 5
Connex VM system ........................................................................................................................... 5
Workflows .......................................................................................................................................... 8

First-time setup ........................................................................................ 9
Connex VM client application .............................................................. 11
Authentication ................................................................................................................................. 11
Allowed values for manually entered vital signs data .............................................................. 12
Concurrency locks .......................................................................................................................... 13
Application configuration .............................................................................................................. 13

User management ................................................................................. 29
Connex VM roles and privileges ................................................................................................... 29
User accounts ................................................................................................................................. 34

Location management .......................................................................... 39
Patient management ............................................................................. 41
Create and admit a new patient ................................................................................................... 41
Import patients ................................................................................................................................ 41
View or edit a patient record ........................................................................................................ 44
Delete a patient ............................................................................................................................... 45

Configuration ......................................................................................... 47
Adjust server configuration settings ........................................................................................... 47
Configure settings for Welch Allyn services .............................................................................. 50
Configure Enterprise Gateway Service ....................................................................................... 54
Import/Export ................................................................................................................................... 58

Maintenance .......................................................................................... 61
Disaster recovery ............................................................................................................................ 61
HL7 connectivity .............................................................................................................................. 65
Auto-installing patches from Microsoft® ................................................................................... 70

iv Contents

Welch Allyn Connex® VM data management system

Reconciliation in the Connex VM system ............................................ 71
Virtual desktop environment ................................................................ 75
Thin client setup .............................................................................................................................. 75

Troubleshooting .................................................................................... 77
Connex VM services ....................................................................................................................... 77
Logs ................................................................................................................................................... 78
Troubleshooting services .............................................................................................................. 80
Troubleshooting network problems ............................................................................................. 82
Troubleshooting specific problems ............................................................................................. 82
Date/Time synchronization between Connex VM and CVSM ................................................. 89
Symptoms and solutions ................................................................................................................ 91

Verify device drivers ............................................................................. 93
Changing the active driver ............................................................................................................ 95

Reference ............................................................................................... 99
Welch Allyn services ...................................................................................................................... 99
Starting, restarting, and stopping a service ............................................................................. 100
TCP/UDP ports used ..................................................................................................................... 102
Medical device connectivity requirements .............................................................................. 103

1

About this guide
This guide is for the Connex VM system Administrator or other IT professionals involved in the
operation and support of the Connex VM system. Topics include configuring, managing, and
troubleshooting the Connex VM data management system.
For information on clinical use and basic administration of the system, refer to the Help menu in
the Connex VM client application.
For information on using the devices that connect to the system, consult the directions for use that
came with the devices or visit our product catalog at welchallyn.com.

Safety symbols
Caution statements in this manual
identify conditions or practices that
could result in damage to the
equipment or other property.

Consult operating instructions.
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Reference documents
Description

Part number

Connex® VM directions for use

100600-2
For each language, a PDF file of the directions for use
(Connex.pdf) is located in the Help Files folder on the
Connex VM installation DVD.
The directions for use can also be found in the Help
menu of the client application.

Connex VSM 6000 Series directions for use
•

Weight sensor directions for use — see
Appendix. Sensors in approved accessories list
will have their own directions for use.

•

SpHB (hemoglobin) sensor directions for use —
see Appendix. Sensors in approved accessories
list will have their own directions for use.

103730 (multilanguage CD)

Connex ProBP™ 3400 directions for use

103701 (multilanguage CD)

Spot Vital Signs LXi directions for use

705310

Spot Vital Signs LXi wireless radio accessory
directions for use (b radio)

4500-921

Spot Vital Signs LXi wireless radio accessory
directions for use (a/b/g radio)

4500-923

Spot Vital Signs directions for use

4200-87E

VSM 300 directions for use, Masimo

810-2250-01

VSM 300 directions for use, Nellcor

810-2252-01
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Introduction
Connex VM system
The Welch Allyn Connex VM data management system is a software system that enables users to
collect patient data from a variety of vital signs devices, enter data manually, review data, and
send data to a Hospital Information System (HIS).

Hardware configurations
The following table shows examples of hardware configurations. Your site might have one or more
configurations deployed.
Symbols:

Data
flow

USB

Configuration

Radio
signal

Serial

Ethernet

Network

Description

Workstation-to-server
A vital signs device is connected to the
client workstation via USB or serial cable.
The user interacts with the Connex
workstation client to pull data from the
device for sending to the server. The user
can also use the workstation client to
push Patient lists to the CVSM device
(not LXi).

Server

|0|0|

Client

Wireless
The vital signs device sends data
wirelessly to the server. The CVSM may
also pull or receive Patient List data from
the server.

Server

Wireless access point
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Configuration

Description

Connex VM vitals kiosk
A vital signs device is connected to the
client kiosk via USB.
A kiosk is a workstation running
Connex VM services and that does not
require workstation client interaction
from a user. Data transfer between the
device and the server occurs without a
user accessing the Connex VM
workstation client.
Device-to-server
An Ethernet connection transmits data
between the vital signs device and the
server.

Server

Welch Allyn Connex VM server and software components
The Welch Allyn Connex VM server and software components store and serve Connex VM system
data and patient medical information.
Component

Description

Welch Allyn Connex®Episodic Receives messages and requests from the devices and processes them for
use by the Connex VM server. The ECS is the device connectivity solution for
Connectivity Service (ECS)
Welch Allyn devices.
Device Connection Protocol
(DCP)

Determines where the ECS resides. Because DCP relies on UDP network
broadcasts, it is assumed that one DCP Server will be installed per network.
If DCP broadcasts (using UDP ports 44435 and/or 7711) are forwarded by the
infrastructure network routers to the Connex VM server, then only one DCP
Server is required.

Welch AllynConnex Client
Services

Facilitate Connex VM client application access to the server.

Connex VM database

Holds Connex VM system data (user accounts, audit logs, and settings) and
patient medical information.

Welch Allyn Enterprise
Gateway Service (EGS)

Facilitates communication between the server and Corepoint Integration
Engine for transmission to external systems (HIS, EMR, and so on). The EGS
connects the Connex VM server to the customer’s enterprise, specifically
HL7-based ADT and hospital information systems.

Enterprise Integration Engine
(EIE) database

Holds inbound ADT data and outbound vital signs data until they are
processed.

HL7/Corepoint software
(integration engine)

Exchanges inbound and outbound messages with the HIS.
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The diagram shows the flow of outbound data. Inbound flow is the reverse of outbound flow.

Item

Shows how data flows through the server in a...

1

Workstation-to-server configuration

2

Wireless configuration
Device-to-server configuration
Connex VM vitals kiosk configuration
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Workflows
The system can capture vital signs from a number of devices used in a variety of workflows. After
the data is saved, the server sends the data immediately to the hospital information system.
The following summarizes the characteristics of each workflow.

Workflow

Description

Available
devices

Wireless

Supports a vital signs device with a wireless radio. The device
also enables clinicians to enter patient identification either
manually or from a barcode scanner. The clinician sends
readings directly from the device to the server. No workstation
user interface is needed. The server sends the data immediately
to the hospital information system. Typically the device is mobile
and running on battery power.

Spot Vital Signs LXi,
Connex Vital Signs
Monitor 6500,
Connex Vital Signs
Monitor 6400 with
internal radio
upgrade

One per bed

Supports a vital signs device with an Ethernet connection. The
Connex Vital Signs
device also enables clinicians to enter patient identification
Monitor 6000 Series
either manually or from a barcode scanner. The clinician sends
readings directly from the device to the server. No workstation
user interface is needed. The server sends the data immediately
to the hospital information system. Typically the device is
stationary and plugged in to an electrical outlet.

Batch upload

Supports a vital signs device that enables clinicians to enter
Spot Vital Signs LXi,
patient identification either manually or from a barcode scanner. Connex Vital Signs
The clinician uses the device to capture multiple patients’ vital
Monitor 6000 Series
signs. The clinician then connects the device to a workstation or
kiosk via USB and uses the client application to import all
readings at once. The server sends the data immediately to the
hospital information system. Typically the device is mobile and
running on battery power.

Mobile computer

Supports a vital signs device and a workstation mounted
together. Both the device and a barcode scanner are connected
to the workstation. The clinician uses the client application to
start vital signs readings and enter additional patient data. After
the clinician saves the data, the server sends the data
immediately to the hospital information system.

Spot Vital Signs,
Spot Vital Signs LXi,
Vital Signs Monitor
300, Connex Vital
Signs Monitor 6000
Series, Connex
ProBP 3400

Monitoring

Supports a device capable of continuous vital signs monitoring.
The device monitors a single patient. The device also enables
clinicians to enter patient identification either manually, using a
barcode scanner, or the client application. The clinician then
uploads the readings to the server which sends the data
immediately to the hospital information system.

Vital Signs Monitor
300, Connex Vital
Signs Monitor 6000
Series

Triage

Supports a device that is permanently attached to a workstation.
A barcode scanner might also be attached to the workstation.
The clinician uses the client application to start vital signs
readings and enter additional patient data. After the clinician
saves the data, the server sends the data immediately to the
hospital information system.

Spot Vital Signs,
Spot Vital Signs LXi,
Vital Signs Monitor
300, Connex Vital
Signs Monitor 6000
Series, Connex
ProBP 3400
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First-time setup
After the system is installed, follow these steps to configure it for use.
Task

For instructions or more information

1. Sign into Connex VM, if not already done. Use
admin (all lower case) as the User Name and
Password. The system requires you to change the
password on this Admin Account. Update installation
documentation accordingly.
2. Set up client application settings.

“Application configuration”

3. Set up user roles and privileges.

“User accounts”

4. Set up user accounts. Ensure that you set up a
“User accounts”
minimum of one administrator account, and one
clinician account. Update installation documentation
accordingly.
5. Set up locations (premium service).

Note

“Location management”

Initial locations are established
during installation. Contact Welch
Allyn to set up additional locations.

6. Create patients.

“Patient management”

7. Configure firewalls, virus software, and router
“Reference”
access lists to allow PartnerConnect and Connex VM
applications and ports. This might need to be done on
workstations, servers, and network equipment, based
on your computer and network environment.

10 First-time setup

Welch Allyn Connex® VM data management system

11

Connex VM client application
The client application (also referred to as “program” in this guide) enables you to perform many
administrative tasks, in addition to recording and displaying patient information and results. In this
guide, instructions for these tasks assume that you are logged on to the application and have the
appropriate level of authorization.
This section covers user authentication, program configuration, and other aspects of the client
application.

Authentication
Depending on the configuration, the server authenticates users by one of these methods:
•

Connex VM user name and password (“standard sign-on”)

•

Active Directory user name and password (“single sign-on”)

Each method controls how the Connex VM application launches.

Standard sign-on
If the server is configured for standard sign-on, the logon window appears whenever a user opens
the client application.
To log on, enter Connex VM user name and password.
To log off, do any of the following:
•

Click Log off in the upper right corner of the main window.

•

In the menu bar, click File > Log off.

Both options end the current session and return the logon window.
Alternatively, click File > Exit to close the program.

Single sign-on
If the server is configured for single sign-on, the user is logged on automatically using Active
Directory credentials. When users open the application, they bypass the logon window, and the
Home page appears.
Connex VM supports one “Connex Default Security Role” when authenticating via single sign-on:
Doctor. So when Connex single sign-on is enabled, all users that log on to the PC using their Active
Directory credentials are automatically logged into Connex VM and are assigned the same Doctor

12 Connex VM client application
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user role. In addition, by default, no Clinician ID or names are associated with this newly created
account.
Note

If the facility plans to use Workstation Capture Vitals or a wireless workflow and
intends to send Clinician ID information with the HL7 message, then the
administrator must update the Connex user account details to include a Clinician ID
and name information.

Administrators can assign different Connex user roles to the newly created User ID in order to
extend administrative privileges to specific user accounts. They can also create user accounts in
advance by creating Connex accounts with user names that match the Domain accounts in the
format of “Domain\UserName” (e.g., Test\John).
To log off, click File > Switch user to end the current session and open the logon window.
Because only those with Connex VM user accounts can log on through this window, this feature is
primarily intended for use by administrators.
Alternatively, click File > Exit to close the program.
In single sign-on mode, neither the Log off button nor File > Log off is available.

Allowed values for manually entered vital signs data
The client application validates manually entered vital signs data. Users can type only values that
meet these requirements.
Measurement

Allowed range

Allowed characters

NIBP systolic

25 mmHg–260 mmHg

0..9

NIBP diastolic

10 mmHg–235 mmHg

0..9

Pulse rate

20–250

0..9

Pulse oximetry (SpO2)

1–100

0..9

Hemoglobin (SpHB)

0 mol/L–15.5 mmol/L (0 g/dL–25 g/dL)

0..9, decimal separator (0..9)

Temperature

68.0 °F–110.0 °F (20.0 °C–43.3 °C)

0..9, decimal separator

Respiration

1–99

0..9

Pain

0–99

0..9

Height

0.0 in–393.3 in (0 cm–999 cm)

0..9, decimal separator (0..9)

Weight

0.0 lb–499.0 lb (0.0 kg–226.3 kg)

0..9, decimal separator

Glucose

0 mg/dl–600 mg/dl (0.0 mmol/l–33.3 mmol/l)

0..9 (0..9, decimal separator)

Comments

Not applicable

Any character
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Concurrency locks
When you start to edit a data record, the record is locked so that other users cannot edit the same
record.
The lock releases automatically if you do not save the record after a designated period. The default
lock time is 20 minutes and can be configured on the Server configuration page in
Administrator tools. If the lock is released, any other user can change the data, and you, as the
user who initially started editing the data record, cannot update the data without re-acquiring the
lock from the other user that accessed the record.
In Administrator tools, you can also search for locked records and release them manually.

Release concurrency locks manually
1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the page, click Locks > Release Locks.

3.

Search for locked records by entity type.
a.

Select an item from the Entity type drop-down list.

b.

Click Search.

Search results appear under Lock item lists.
4.

Release locks, using one of the following methods:
•

For a specific record: Click the record to select it. At the bottom of the page, click
Release locks.

•

For all records: Click Release all locks.

Application configuration
In Tools > Options, many aspects of the client application can be customized. Depending on the
privileges assigned to them, users can customize settings for themselves or for others.

The panel to the far left lists all users, installations (“machines”), and locations in the Connex VM
system. Click each tab—Users, Installations, Locations—and the items that appear in the
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panel below to access the corresponding settings. The Create Group button is used by
customers that want to create sub-groups of users that share settings that are different than other
users. The Delete Group button removes groups that are not needed, or were created in error.
The settings options presented on these tabs control how the Connex VM application behaves.
Your selections will affect such things as how data appears on screen and in printouts, search
options, and default settings for parameter measurements and alerts.

Use default behavior
The option to Use default is available with many settings in the Tools > Options window, but
you must understand the behavior of this option, particularly the “parent-child” and inheritance
characteristics, to use it effectively.
Default settings are determined by the “parent” of an item in a specific group. If Yes is set as the
default for a parent item, then every item under it (“child”) has the same default.
When a user logs on to the client application, the application determines which settings take effect
based on a hierarchy:
•

If a value is set for the user, that value is used. If Use default is selected, then the value of
the parent is used. It is the value shown in the parenthesis.

•

The value is inherited from the User Group, if it exists, that the user is logged under. If Use
default is selected at this level, then the value of the parent is used. It is the value shown in the
parenthesis.

•

The value is inherited from the USERS node. If Use default is selected at this level, then it is
defined by the option displayed in the parenthesis after “Use Default.”

For example, defaults set for Vital Signs on the Users tab apply to all the parameter settings
below it if you select Use default. The current default settings appear in parentheses after Use
default or in a block of settings options:
•

Use default (Newest to oldest)

•

Use default (No)

•

Use default (Use current user)

•

Use default (View selected patient record)

You can override default settings by selecting any radio button option other than Use default.
These individual selections are not affected by any setting changes at the parent level.
If you select Use default and the default settings subsequently change at the parent level, the
new default settings take effect at the child level without user notification. In other words, if any
default value at the parent level changes, the default values for all the dependent items
automatically change without user notification.
Note

Changes to defaults at the dependent or child level occur without user
notification.

Users tab
You can set the same limits for all users or customize limits for each user.
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Item

Affects...

USERS

All users in the USERS list.

A specific user in the USERS list That user only

Hierarchy

These settings override those in
USERS.
If Use default value is
selected, the value from USERS
takes effect.

To change settings for all users or a specific user, first click Edit at the bottom of the screen, then
clear the Use default check box.
Tools

> Options > Users tab > Application > Searches
Searches settings provides filters to narrow the display of search results.
Setting

Description

Standard searches (for
example, My locations)

•

•

Available searches: The standard (built-in) searches that appear
in the Show list on the Home page. Options include Use
default standard searches.
Search options: The settings for the standard searches. Options
include Use default locations. To view or change these
settings, you must select the search name. Before you can make
changes to My locations, you must clear the Use default
locations check box.

Saved searches

•
•

Tools

The saved searches that appear in the Show list on the Home
page. Options include Use default saved searches.
Additional searches: Customized searches that appear in the
Show list on the Home page. (Used primarily in Cardiology offices
to create a specific list of a doctor's patients.)

> Options > Users tab > Application > Patient
Patient settings presents default and alternative options for what occurs when you double-click
a patient name.
Setting

Description

Default patient action

The action that occurs after the user double-clicks a patient name.
•
Use default
•
View selected patient record
•
Acquire vitals
•
Do nothing

Show patient location

•
•

Use default
Yes: Patient locations appear at the top of the Capture Vital Signs
window and at the top of the patient record.
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Description
•

Tools

No: Patient locations do not appear.

> Options > Users tab > Plugins > Vital Signs > General
Setting

Description

Available measurements The measurements that appear when the user is capturing vital signs or
viewing patient records. Options include Use default. Before you can
make changes to the list of displayed measurements, you must clear the

Use default check box.
•
NIBP
•
Pulse rate
•
Pulse Oximetry
•
Hemoglobin
•
Temperature
•
Respiration
•
Pain
•
Height
•
Weight
•
Glucose
•
Comments
Display modifiers

•
•

Use default
Yes: If any modifiers (site, method, position, etc.) were entered

•

No: Modifiers remain in the database but do not appear in the patient

during a vital signs capture, they appear in the patient record.
record.

Patient history ordering The order in which patient information appears in a patient record and on
graphs.
•
Use default
•
Newest to oldest
•
Oldest to newest

Missing clinician action

The action that occurs if the clinician ID is unspecified during a batch
import of vital signs readings.
•
Use default
•
Use current user
•
Keep empty

Installations tab
You can set the same limits for all machines or customize limits for each machine.
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Item

Affects...

MACHINES

All machines in the MACHINES
list.

A specific machine in the

That machine only

MACHINES list

Hierarchy

These settings override those in

MACHINES.
If Use default value is
selected, the value from

MACHINES takes effect.
To change settings for all machines or a specific machine, first click Edit at the bottom of the
screen, then clear the Use default check box.
Tools

> Options > Installations tab > Application > General
General settings controls the formats of clinician and non-clinician names, the date, and the
time. Options for these formats include Use default. The default Search settings cannot be
deleted.
Setting

Description

Search Results

The number of pages or results you want to appear when using the Search
function.
•
Use default
•
Paging enabled: The number of results presented per page if
paging is enabled.
•
Maximum results: The maximum number of results presented.

Show Search tab on
login

•
•
•

Use default
Yes: The Search tab is present by default.
No: The Search tab is absent by default. The user can open it from
the menu bar: View > Search.

Show confirmation
dialog on log off

•
•
•

Use default
Yes: A confirmation prompt appears when the user logs off.
No: No confirmation prompt appears when the user logs off.

Automatic logout on
idle

•
•

Use default
Yes: Whenever the program has been unused for the designated idle

•

Automatic idle logout
timeout

period, it logs the user off. In single sign-on configurations, which
require that users log on only to the operating system, the program
closes instead.
No: The program does not log users off or close automatically.

The number of minutes in the idle period. Options include Use default.
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> Options > Installations tab > Application > Localization
Localization settings controls system display language and punctuation used in decimals.
Setting

Description

Languages available

This option sets the language used by the Connex VM program. The first
item in the list attempts to match the Connex VM language to the language
selected in Windows. If not available, English is chosen. The remaining
items in the list specify a language directly.
•
Use default
•
German (Germany)
•
English (United States)
•
Spanish (Spain)
•
French (France)

Note

Decimal separator

After changing the language, log off and back on to make
the setting take full effect.

This option sets the punctuation used to separate whole numbers from
decimals.
•
Use default
•
Period
•
Comma

Custom modifiers
The option to customize modifiers exists for all vital signs measurements in the following
workflows: Computer-based vitals, Batch, and Triage. They do not apply in the Wireless or Push
from Device/Auto Reconcile workflows. If modifiers are available on the device in either of these
workflows, they cannot be changed. The descriptions presented here apply only to modifiers
available within the Connex VM software.
Before you can create a custom modifier, you must clear the Use default check box.
Setting

Description

Custom modifier

New modifier value created by administrator.
•
Use default
•
Available: Indicates whether Custom modifiers appear on the
Capture Vital Signs screen.
•
Drop box: Open a window to customize modifiers.
○ Editable: Modify only what appears in the Label field.
○ Label: Either use the default Custom label or replace it with a
new label.
○ Edit: Modify the name of a list item.
○ Up: Move the list item higher in the list.
○ Down: Move the list item lower in the list.
○ Add...: Create a new list item.
○ Delete: Delete a list item. You can only delete items added to
the standard list.
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> Options > Installations tab > Plugins > Vital Signs > NIBP
Setting

Description

General
Show MAP

•
•
•

Use default
Yes: Mean arterial pressure (MAP) appears.
No: MAP does not appear.

NIBP modifiers

•

Location modifier: The anatomical site where the measurement
was taken. Options include None, Unknown, L Arm, R Arm, L
Leg, R Leg, and any locations you might add.
○ Use default
○ Available
○ Label: Either use the default Cuff location label or replace it
with a new label.
Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to
the standard list.
Position modifier: The patient’s position when the measurement
was taken. Options include None, Unknown, Lying, Sitting,
Standing, and any positions you might add.

○
○
○
○
○

•

○
○
○

Use default
Available
Label: Either use the default Position label or replace it with

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

a new label.

•

the standard list.

Cuff size modifier: The size of the cuff. Options include None,
Unknown, Neo 1, Neo 2, Neo 3, Neo 4, Neo 5, Small
infant, Infant, Small child, Child, Small adult, Adult,
Adult long, Large adult, Large adult long, Thigh,and any
cuff sizes you might add.

○
○
○

Use default
Available
Label: Either use the default Cuff size label or replace it with

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

a new label.

•

the standard list.

Custom modifier: New modifier value created by administrator.

(See description presented earlier in this section.)
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> Options > Installations tab > Plugins > Vital Signs > Glucose
Setting

Description

Glucose modifier

Custom modifier: New modifier value created by administrator. (See
description presented earlier in this section.)

> Options > Installations tab > Plugins > Vital Signs > Pulse rate
Setting

Description

Pulse rate modifiers

•

Site modifier: The anatomical site where the measurement was
taken. Options include None, Unknown, Left, Right, and any
sites you might add.

○
○
○

Use default
Available
Label: Either use the default Site label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

•

the standard list.

Method modifier: The method by which the measurement was
taken. Options include None, Unknown, Auscultate,
Doppler, Palpation, and any methods you might add.
○ Use default
○ Available
○ Label: Either use the default Method label or replace it with a
custom label.

○
○
○
○
○
•

the standard list.

Position modifier: The patient’s position when the measurement
was taken. Options include None, Unknown, Lying, Sitting,
Standing, and any positions you might add.
○ Use default
○ Available
○ Label: Either use the default Position label or replace it with
a custom label.
Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to
the standard list.
Custom modifier: New modifier value created by administrator.
(See description presented earlier in this section.)

○
○
○
○
○

•

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to
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> Options > Installations tab > Plugins > Vital Signs > Height
Setting

Description

Height modifiers

•

Quality modifier: The quality of the measurement. Options
include None, Unknown, Actual, Estimated, and any quality
descriptors you might add.

○
○
○

Use default
Available
Label: Either use the default Quality label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

•

the standard list.

Custom modifier: New modifier value created by administrator.

(See description presented earlier in this section.)

Tools

> Options > Installations tab > Plugins > Vital Signs > Hemoglobin
Setting

Description

Hemoglobin modifiers

•

Mode modifier: The source of the measurement. Options include
None, Unknown, Arterial, Venous, and any modes you might
add.

○
○
○

Use default
Available
Label: Either use the default Mode label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

•

the standard list.

Custom modifier: New modifier value created by administrator.

(See description presented earlier in this section.)

Tools

> Options > Installations tab > Plugins > Vital Signs > Pain
Setting

Description

Pain modifiers

•

Method modifier: The method by which the rating was taken.
Options include None, Unknown, Verbal, Non-verbal, and
any methods you might add.
○
○
○

Use default
Available
Label: Either use the default Method label or replace it with a
custom label.
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Description
○
○
○
○
○
•

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to
the standard list.

Custom modifier: New modifier value created by administrator.

(See description presented earlier in this section.)

Tools

> Options > Installations tab > Plugins > Vital Signs > Pulse Oximetry
Setting

Description

Pulse oximetry modifiers

•

Method modifier: The method by which the measurement was
taken. Options include None, Unknown, Aerosal/humidifier
mask, Face tent, Mask, Nasal cannula, Nonrebreather,
Partial rebreather, T-piece, Tracheostomy collar,
Ventilator, Venturi mask, Room air, Oxymizer, and any
methods you might add.
○
○
○

Use default
Available
Label: Either use the default Method label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

•

the standard list.

Location modifier: The anatomical site where the measurement
was taken. Options include None, Unknown, Ear, Finger, Toe,
Forehead, and any locations you might add.
○ Use default
○ Available
○ Label: Either use the default Location label or replace it with
a custom label.

○
○
○
○
○
•

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to
the standard list.

Custom modifier: New modifier value created by administrator.

(See description presented earlier in this section.)
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> Options > Installations tab > Plugins > Vital Signs > Respiration
Setting

Description

Respiration modifiers

•

Method modifier: The method by which the measurement was
taken. Options include None, Unknown, Assisted by
ventilator, Controlled by ventilator, Spontaneous, and
any methods you might add.
○
○
○

Use default
Available
Label: Either use the default Method label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

•

the standard list.

Position modifier: The patient’s position when the measurement
was taken. Options include None, Unknown, Lying, Sitting,
Standing, and any positions you might add.
○ Use default
○ Available
○ Label: Either use the default Position label or replace it with
a custom label.
Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to
the standard list.
Custom modifier: New modifier value created by administrator.
(See description presented earlier in this section.)

○
○
○
○
○

•

Tools

> Options > Installations tab > Plugins > Vital Signs > Temperature
Setting

Description

Temperature modifiers

•

Mode modifier: The anatomical site where the measurement was
taken. Options include None, Unknown, Oral, Rectal,
Pediatric axillary, Calibration key, Adult axillary,
Tympanic, and any modes you might add.
○
○
○

Use default
Available
Label: Either use the default Mode label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

the standard list.
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Description
•

Tools

Custom modifier: New modifier value created by administrator.
(See description presented earlier in this section.)

> Options > Installations tab > Plugins > Vital Signs > Weight
Setting

Description

General
Show BMI

•
•
•

Use default
Yes: Body Mass Index (BMI) is displayed.
No: BMI is not displayed.

Weight modifiers

•

Quality modifier: The quality of the measurement. Options
include None, Unknown, Actual, Dry, Estimated, and any
quality descriptors you might add.

○
○
○

Use default
Available
Label: Either use the default Quality label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

•

the standard list.

Method modifier: The method by which the rating was taken.
Options include None, Unknown, Bed, Chair, Standing, and

any methods you might add.

○
○
○

Use default
Available
Label: Either use the default Method label or replace it with a

○
○
○
○
○

Edit: Modify the name of a list item.
Up: Move the list item higher in the list.
Down: Move the list item lower in the list.
Add...: Create a new list item.
Delete: Delete a list item. You can only delete items added to

custom label.

•

the standard list.

Custom modifier: New modifier value created by administrator.

(See description presented earlier in this section.)

Tools

> Options > Installations tab > Plugins > Vital Signs > Printing
Auto print options controls when printing will occur and what templates will be used.
Setting

Description

Auto print options

•

Print after test taken
○ Use default
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Setting

Description

•

○ Yes: Results are automatically printed whenever a test is taken.
○ No: No automatic printouts occur when a test is taken.
Print after test saved/updated
○ Use default
○ Yes: Results are automatically printed whenever a test is saved
○

or updated (edited and resaved).
No: No automatic printouts occur when a test is saved or
updated.

Reports to print after
test taken

The types of reports that print after tests are taken.
•
Use default
•
ImportReportTemplate: Data imported from the device.
•
ListReportTemplate: Generic report template used for internal
tabular data reports. Not to be used with printing after test taken.
•
PatientDetailsTemplate: Currently unused.
•
VitalSignsReviewGraphTemplate: Data plotted on a graph.
•
VitalSignsReviewTabularTemplate: Numerical data in a
table.

Reports to print after
test saved/updated

The types of reports that print after tests are saved or updated (edited and
resaved). (Same list of reports as above.)

Locations tab
You can set the same limits for all locations or customize limits for each location.
Item

Affects...

LOCATIONS

All locations

A location in the LOCATIONS
list

That location only

Hierarchy

These settings override those in
LOCATIONS.
If Use default value is
selected, the value from
LOCATIONS takes effect.

To change settings for all locations or a specific location, first click Edit at the bottom of the
screen, then clear the Use default check box.
Tools

> Options > Locations tab > Plugins > Vital Signs > NIBP
Setting

Description

NIBP unit

•
•
•
•
•
•

Use default
pa
kPa
torr
mmHg
mbar

26 Connex VM client application

Setting

NIBP alert ranges

Tools

Tools

Tools

Welch Allyn Connex® VM data management system

Description
•
•
•

bar
atm
Psi

•
•
•
•
•

Use default value
Minimum systolic
Maximum systolic
Minimum diastolic
Maximum diastolic

> Options > Locations tab > Plugins > Vital Signs > Pulse rate
Setting

Description

Pulse alert range

•
•
•

> Options > Locations tab > Plugins > Vital Signs > Pulse Oximetry
Setting

Description

SpO2 alert value

•
•

Use default value
Minimum %

> Options > Locations tab > Plugins > Vital Signs > Hemoglobin
Setting

Description

Hemoglobin unit

•
•
•

Hemoglobin alert range •
•
•
•
•

Tools

Use default value
Minimum
Maximum

Use default
g/dl
mmol/L
Use default value
Minimum mmol/L
Maximum mmol/L
Minimum g/dl
Maximum g/dl

> Options > Locations tab > Plugins > Vital Signs > Temperature
Setting

Description

Temperature unit

•
•

Use default
Celsius
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Setting

Description
•
•
•

Temperature alert range •
•
•

Tools

Tools

Tools

Tools

Tools

Fahrenheit
Celsius with conversion
Fahrenheit with conversion
Use default value
Minimum
Maximum

> Options > Locations tab > Plugins > Vital Signs > Respiration
Setting

Description

Respiration alert range

•
•
•

Use default value
Minimum
Maximum

> Options > Locations tab > Plugins > Vital Signs > Pain
Setting

Description

Pain alert level

•
•

Use default value
Maximum

> Options > Locations tab > Plugins > Vital Signs > Height
Setting

Description

Height unit

•
•
•

Use default
cm
in

> Options > Locations tab > Plugins > Vital Signs > Weight
Setting

Description

Weight unit

•
•
•

Use default
kg
lb

> Options > Locations tab > Plugins > Vital Signs > Glucose
Setting

Description

Glucose unit

•

Use default
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Description
•
•

mmol/l
mg/dl

•
•
•

Use default value
Minimum
Maximum
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User management
Connex VM roles and privileges
Roles and associated privileges grant users permission to perform designated tasks in the system.
During installation, default roles are created. In Administration > Roles and privileges, you
can view and modify these roles, create new roles, and delete roles to suit your facility’s needs.
You can then assign roles to users when you create user accounts.

Default roles and associated privileges
The table compares the default roles created during installation.
Note

It is strongly recommended that you deselect Change own setting and Change
group setting for the User, Manager, and Doctor roles. Otherwise, users could,
for example, add modifier values that everyone could use, and those modifiers
would not appear in vital signs readings sent to the HIS.

Privilege

Manager

User

Admin

Admin System

X

Change any setting

X

Change group setting

X

Doctor

X

Manage configurations

X

Manage roles

X

Manage users

X

Cancel any edit

X

Change own setting

X

X

X

X

Change password

X

X

X

X

Manage custom searches

X

Create patient

X

X
X

X

X
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Privilege

Manager

User

Admin

Doctor

X

Delete patient
Edit any patient

X

X

X

Edit assigned patient

X

X

X

X

Edit personal info

X

X

X

X

View any patient

X

X

X

X

View assigned patient

X

X

X

Assign patients

X

X

X

X

Create test

X

X

X

X

X

Delete test
Edit any test
Note

X

X

X

If you plan to use the Import test
feature, you must grant this
privilege for the User role. Making
this a default privilege for the User
role means all Users you create will
have this privilege by default.

Edit assigned test

X

X

X

X

Export test

X

X

X

X

Import test

X

X

X

X

Use telemedicine

X

X

X

View any test

X

X

X

View assigned test

X

X

X

Assign tests

X

X

X

X

Purge entity

X

Restore entity

X

Create a new role
1.

In the menu bar, click Administration > Roles and privileges.
The Roles and Privileges window appears.

2.

In the lower part of the left pane, click Create new role.
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3.

In the Privileges pane, type the new role name in the New Role box.

4.

Select check boxes next to privileges that you want to associate with the role.

5.

Click Save.

Modify a role
1.

In the menu bar, click Administration > Roles and privileges.
The Roles and Privileges window appears.

2.

In the left pane, click a role.

3.

Click Edit.

4.

In the Privileges pane, select or clear privilege check boxes.

5.

Click Save.

Copy a role
You can create a new role with similar privileges or the same privileges as an existing role.
1.

In the menu bar, click Administration > Roles and privileges.
The Roles and Privileges window appears.

2.

Next to the role you are copying, click

and select Copy.

3.

In the Privileges pane, type the new role name in the Copy Of (role name) box.

4.

(Optional) Select and clear check boxes next to privilege names.

5.

Click Save.

Delete a role
1.

In the menu bar, click Administration > Roles and privileges.
The Roles and Privileges window appears.

2.

Next to the role, click

and select Delete.

Privileges
The following tables describe the privileges in the Roles and Privileges window. To open this
window, click Administration > Roles and privileges.
Some privileges are part of a hierarchical family that represents levels of authorization for a
particular task. When one of these privileges is selected for a role, it supersedes any lower-level
privileges that are also selected.
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Administration
Privilege

Superseded
privileges

Description

Admin System

If selected, the administrator can do the following:
•
edit the system configuration
•
create, delete, or list the configuration restore
points within the system
•
add an entity (patient, test, etc.) that does not
allow updates or deletes
•
register and unregister test types and
measurement definitions within the system

Change any setting* Change group
setting
Change own
setting

If selected, the user can view and edit the settings of
any configurable element in Tools > Options.

Change group
setting*

If selected, the user can view and edit the settings of
his user account and immediate parent group in
Tools > Options.

Change own
setting

Manage
configurations*

If selected, the user can view and edit the settings of
any configurable element in the app-machine tree.

Manage roles*

If selected, the user can view and make changes to
roles in Administration > Roles and
privileges.

Manage users*

If selected, the user has access to the flyout menu
items in search results in Search > Users.

Cancel any edit*

If selected, the user can release locks on the

Release Locks page.

Users
Privilege
Change own
setting*

Superseded
privileges

Description

If selected, the user can view and edit the settings of
his user account in Tools > Options.
If not selected, the user can view the settings of his
user account in Tools > Options but cannot edit
them.

Change password

If selected, the user can change his password.

Manage custom
searches

If selected, the user can create and edit saved
searches.
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Patient records
Privilege

Superseded
privileges

Description

Create patient

If selected, the user can create a new patient.

Delete patient

If selected, the user can delete a patient.

Edit any patient

Edit assigned
patient

If selected, the user can edit information in the
Patient Summary window for any patient.

Edit assigned
patient

If selected, the user can edit information in the
Patient Summary window for only assigned patients.

Edit personal info

If selected, the user can edit his user account
information. To enable this privilege, the Manage
users privilege must also be selected.

View any patient

View assigned
patient

If selected, the user can view the patient details for
any patient.

View assigned
patient

If selected, the user can view the patient details for
only assigned patients.

Assign patients

If selected, the Assign/Unassign button is
enabled for patient search results.

Testing
Privilege

Superseded
privileges

Description

Create test

If selected, the user can create tests, including vital
signs readings.

Delete test

If selected, the user can delete tests/place them in
the recycle bin, including vital signs readings.

Edit any test

If selected, the user can edit tests, including vital
signs readings.

Edit assigned test

If selected, the user can edit only tests he or she has
been assigned.

Note

If the Import test feature is enabled,
this privilege is required.

Export test

If selected, the user can export tests out of the
system.

Import test

If selected, the user can import tests from an external
data source.
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Privilege

Superseded
privileges

Use telemedicine

View any test

Description

If selected, the user can access the system from a
remote location.

View assigned test

If selected, the user can view any test in the system.

View assigned test

If selected, the user can view only those tests he or
she is assigned.

Assign tests

If selected, the user can assign another clinician to a
test, but no updates to the test are allowed.

* It is strongly recommended that these privileges be made available for administrators only.
Otherwise, users could, for example, add modifier values that everyone could use, and those
modifiers would not appear in vital signs readings sent to the HIS.

Other
Privilege

Superseded
privileges

Description

Purge entity

If selected, the user can permanently remove data
from the system by emptying the recycle bin.

Restore entity

If selected, the user can restore data from the recycle
bin back into the system.

User accounts
Create a user account and assign roles
1.

In the menu bar, click Administration > New user.
The Create/Modify User window appears.

2.

Specify account details.
a.

Enter ID information.

b.

(Optional) Select the Account is active check box.
If you do not select this box, you can activate the account later.

c.

(Optional) Select the Change the password at next logon check box.
The password is set, and the user can change it at the next logon.

d.

Select the Set password check box, and then enter and confirm the password.

3.

Type the user title and name in the Clinician name boxes.

4.

Select USERS or the appropriate sub-group desired as the Settings Group. This setting
affects the values and display options available to the user as the Settings group.
Note

Do not leave this field blank. If you do, some administrative features
of Connex VM will not function properly.
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5.

Place check boxes next to one or more user roles you want to associate with this user
account.

6.

Click Save.
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Clinician ID behavior—default operation
When a Clinician ID is entered on a vital signs monitoring device (scanned or typed), the scanned
value is sent to Connex VM with the captured vitals.
By default, Connex VM will look for the entered Clinician ID in the Connex VM user list, marry the
Clinician Name details with the Clinician ID, and use the values in the OBR-10 field and the OBX-16
field within the HL7 ORU message sent to the EMR.
Sample OBR and OBX segment with Known Clinician ID(shown underscored and in
boldface)
OBR||WA11222010083337660|61|RC1|||20101122083142|||C0001^Nancy^Nurse^L^^Mrs.
OBX|1|NM|TEMP^Temperature^L|1|97.9|F|||||R|||20101122083140||
C0001^Nancy^Nurse^^^Mrs.
OBX|2|ST|TEMPSITE^TEMPERATURE SITE^L|1|Oral||||||R|||20101122083140||
C0001^Nancy^Nurse^^^Mrs.
Note

The text on your screen is unlikely to wrap to the next line as it does here.

In contrast, if Connex VM cannot find the entered Clinician ID in the user list, then it will send the
entered Clinician ID along with a fixed string of “New Clinician First Name” and “New Clinician
Last Name” in the OBR-10 and OBX-16 fields within the HL7 message sent to the EMR.
Sample OBR and OBX segment with Unknown Clinician ID (shown underscored and in
boldface)
OBR||WA11222010083948398|62|RC1|||20101122083747|||E1255^New Clinician Last
Name^New Clinician First
OBX|1|NM|TEMP^Temperature^L|1|97.7|F|||||R|||20101122083743||E1255^New Clinician Last
Name^New Clinician First
OBX|2|ST|TEMPSITE^TEMPERATURE SITE^L|1|Oral||||||R|||20101122083743||E1255^New
Clinician Last Name^New Clinician First
Note

The text on your screen is unlikely to wrap to the next line as it does here.

Note

When you create a User in Connex VM that is associated with a Clinician ID already
in Connex VM, you will be asked if you want to continue using the Clinician ID that
already exists. If you answer Yes, the First and Last Name associated with the
Clinician ID in Connex VM overwrite the First and Last Name in the new User
account. If this isn’t the outcome you want, you must reopen and edit the record so
that the desired First and Last Name appear in the User account.
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Import users
You can create a batch of user accounts by importing user information from a comma-delimited
(.csv) file.
This task is for adding new users only. If you import a record for a user who already
has an account, the existing record is not updated.

Note

Prepare file for user import
To import new user accounts into the system, prepare a .csv file according to these guidelines.
1.

Export user information from another source to a comma delimited (.csv) file.

2.

Make sure that the file contains the following:
•

The first line must contain the following header:
UserName,ClinicianNumber,Prefix,FirstName,MiddleName,LastName,Suffix,IsActive,
PasswordChangeRequired,ManagerRole,UserRole,AdminRole,DoctorRole
Note

3.

Group Setting is not available during Import and must be
manually defined.

•

Each subsequent line must contain the information for one user. UserName is required,
and one role must be set to true. Optional fields must be delimited even if they do not
contain data. For example:
SMITH,XXXYYYZZZ,Dr,John,Adam,Smith,Jr.,true,true,true,,,

•

If any field contains leading zeros, do not enclose that field in double quotes. For example,
if a user’s clinician number is 000345, do not type “000345” in the CSV file. This is a change
from previous Connex VM releases.

Save the file with a .csv extension.

Field name

Description

Possible value

UserName

Connex VM user name.

Alphanumeric characters up to 50
characters.

ClinicianNumber

User’s clinician ID.

Alphanumeric characters up to 20
characters.

Prefix

Title, for example, Dr, Mr., or Mrs.

Alphanumeric characters up to 5
characters.

FirstName

Alphanumeric characters up to 20
characters.

MiddleName

Alphanumeric characters up to 20
characters.

LastName

Alphanumeric characters up to 30
characters.

Suffix

Generational suffix, for example, Jr. Alphanumeric characters up to 5
or Sr.
characters.

IsActive

Indicates whether this user
account is active.

True or false.
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Description
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Possible value
No value, or any value other than
true, is treated as false.
If this field is set to false, the user
cannot log on to the system.

PasswordChangeRequired

ManagerRole
UserRole

True or false.

Indicates the role assigned to the
user.

True or false.

These four roles are created at
installation. If you deleted one of
these roles or created additional
roles in the Roles and Privileges
window, see the note below.

AdminRole
DoctorRole

Note

Indicates whether password
change is required on next logon.

No value, or any value other than
true, is treated as false.

No value, or any value other than
true, is treated as false.
You must assign the user at least
one role.

If you created additional roles in the Roles and Privileges window, you can add
fields to the file after DoctorRole. The field name must contain the role name plus
the word “Role.” For example, if you added a new role called “SuperAdmin,” the
field name must be “SuperAdminRole.”
If you deleted a default role in the Roles and Privileges window, remove the field for
the deleted role.

Import user account file
After you prepare a .csv file of user information, follow these steps to import the data into the
system.
1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the screen, click Import > Import users.

3.

Next to the Select file box, click Browse.
The Select File to Import window appears.

4.

Browse to the comma delimited file that you created.

5.

Double-click the file.
The file name appears in the Select file box.

6.

Click Import.

The default password for a new user is WelchAllyn.

Modify a user account
1.

Click the Search tab or go to View > Search.

2.

Click Users.

3.

Enter your search criteria.

4.

Click Search.
A list appears.
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Next to the user ID, click

and select Edit user details.

The Modify User window appears.
6.

Click Edit.

7.

Modify information.

8.

Click Save.

Deactivate or activate a user account
1.

Click the Search tab or go to View > Search.

2.

Click Users.

3.

Enter your search criteria.

4.

Click Search.
A list appears.

5.

Next to the user ID, click

and select Edit user details.

The Modify User window appears.
6.

Click Edit.

7.

Clear or select the Account is active check box.

8.

Click Save.

Delete a user account
1.

Click the Search tab or go to View > Search.

2.

Click Users.

3.

Enter your search criteria.

4.

Click Search.
A list appears.

5.

Next to the user ID, click

and select Delete.
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Location management
The Location Management page (available from the menu bar under Administration >
Administrator tools) provides the ability to add locations, edit location names, and delete
locations.
The location associated with a patient must be defined via Location Management for vital
signs capture to work as expected. A location mismatch will affect patient result display. Excessive
patient location mismatches might impact system operation. Because Location Management
has a profound effect on proper functioning of the system, only Welch Allyn Technical Support
personnel can make adjustments to locations. Contact your Technical Support representative for
more information.
Locations are also used to manage patient list retrievals with the CVSM device. The CVSM
Location ID must be populated with a name which corresponds to a location populated within
ConnexVM. Using this feature at the device will send a request to ConnexVM containing the
location ID from the device.
ConnexVM will then return a list of patients to the device which represents a list of admitted
patients in ConnexVM for that location at the time the request is received.
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Create and admit a new patient
If the configuration at your facility allows it, you can create a patient by following these steps.
Note

In many configurations, patient records are automatically kept in-sync with the
hospital information system. In those configurations, it is generally not necessary or
even desirable to enter patient information manually.

1.

Select File > Create new patient.

2.

Enter patient information.

3.

Click Save.
The new patient has a admit status of Admitted in the Connex VM program.

Import patients
You can create a batch of patient records by importing patient information from a comma-delimited
(.csv) file.
Note

This task is for adding new patients only. If you import a record for a patient that
already exists in the system, the existing record does not update.

Prepare file for patient import
To import new patient records into the system, prepare a .csv file according to these guidelines.
1.

Export patient information from another source to a comma delimited (.csv) file.

2.

Ensure that the first line in the file contains the header shown below.
FirstName,LastName,MiddleName,MRN,Prefix,Suffix,DOB,AdmissionStatus,AdmitDateTime,
Building,Floor,Room,Bed,Facility,Unit,Gender,AdmitStatus,StreetAddress,StateProvince,
PostalCode,OtherDesignation,County,Country,City,Value,AreaCode,CountryCode,
Extension,LocalNumber,Race

3.

Ensure that each subsequent line contains information for one patient record. FirstName,
LastName, MRN, and DOB are required. Optional fields must be delimited even if they do not
contain data.
Example of a patient record with all fields filled in:
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Mike,Smith,Alan,XXXXYZZZZ,Mr,Jr,1/13/1980,yes,10/10/2009,Building 1,Floor 1,1,77,Facility
1,Unit 1,2,2,4341 State Street Road,NY,13153,PO Box,Onondaga,USA,Skaneateles
Falls,mike.email@welchallyn.com,800,1,11,8002892501,2
Example of a patient record with some optional fields left blank:
Mike,Smith,Alan,XXXXYZZZZ,,,1/13/1980,yes,10/10/2009,Building 1,Floor 1,1,77,Facility 1,Unit
1,2,2,4341 State Street Road,NY,13153,PO Box,Onondaga,USA,Skaneateles Falls,,,,,
8002892501,2
4.

Save the file with a .csv extension.

Field name

Description

Possible value

FirstName*

Alphanumeric characters up to 20
characters.

LastName*

Alphanumeric characters up to 30
characters.

MiddleName

Alphanumeric characters up to 20
characters.

MRN*

Medical record number.

Alphanumeric characters up to 20
characters.

Prefix

Title, for example, Mr., Mrs., or Miss.

Alphanumeric characters up to 5
characters.

Suffix

Generational suffix, for example, Jr. or Sr. Alphanumeric characters up to 5
characters.

DOB*

Date of birth.

A date in Windows short date format.

AdmissionStatus

Indicates whether a visit needs to be
created.

Yes or no.

AdmitDateTime

If the value is yes, the file must also
include AdmitDateTime, Floor, Room, Bed,
Facility, Unit, and AdmitStatus.

Date on which the patient was admitted to A date in Windows short date format.
the location for this visit.

Building

Alphanumeric characters up to 20
characters.

Floor

Alphanumeric characters up to 20
characters.

Room

Alphanumeric characters up to 20
characters.

Bed

Alphanumeric characters up to 20
characters.

Facility

Alphanumeric characters up to 20
characters.
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Field name

Description

Possible value

Unit

Alphanumeric characters up to 20
characters.

Gender

The following numbers can be used:
•
0 = Unknown
•
1 = Female
•
2 = Male
•
3 = Other
•
4 = Ambiguous
•
5 = Irrelevant

AdmitStatus

Defines the stage of the patient's
admittance to a location.

The following numbers can be used:
•
0 = Unknown
•
1 = Preadmitted
•
2 = Admitted
•
3 = Discharged

StreetAddress

Alphanumeric characters up to 200
characters.

StateProvince

Alphanumeric characters up to 30
characters.

PostalCode

Alphanumeric characters up to 15
characters.

OtherDesignation

Additional information about an address
such as a post office box or an apartment
number.

Alphanumeric characters up to 50
characters.

County

Alphanumeric characters up to 50
characters.

Country

Alphanumeric characters up to 50
characters.

City

Alphanumeric characters up to 30
characters.

Value

Email address.

Alphanumeric characters up to 100
characters.

AreaCode

Telephone area code.

Alphanumeric characters up to 5
characters.

CountryCode

Telephone country code

Alphanumeric characters up to 5
characters.

Extension

Telephone extension number.

Alphanumeric characters up to 5
characters.

LocalNumber

Local telephone number.

Alphanumeric characters up to 20
characters.
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Description

Possible value

Race

The following numbers can be used:
•
0 = Unknown
•
1 = Other
•
2 = White
•
3 = Black or African American
•
4 = American Indian or Alaska Native
•
5 = Asian
•
6 = Native Hawaiian and/or Pacific
Islander

* Required field.

Import patient record file
After you prepare a .csv file of patient information, follow these steps to import the data into the
system.
1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the screen, click Import > Import patients.

3.

Next to the Select file box, click Browse.
The Select File to Import window appears.

4.

Browse to the comma delimited file that you created.

5.

Double-click the file.
The file name appears in the Select file box.

6.

Click Import.

View or edit a patient record
1.

Locate the correct patient name in the list on your Home page.

2.

Next to the patient name, click

and click View patient record.

The Patient record page appears.

3.

Next to the patient's name, click

and then click Patient details.

The Patient Details window appears.
4.

(Optional) Click Edit. Add, change, or remove patient information.
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Delete a patient
When you delete a patient, the patient record moves to the recycle bin. The deleted record cannot
be viewed, updated, or restored.
1.

On the Home page or Search page, click

2.

Select Delete Patient.

next to the patient name.
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Adjust server configuration settings
In Administrator tools, the Server configuration page enables you to configure settings,
such as password policy, patient matching, patient IDs, authentication, auditing, search results,
location format, and concurrency lock timeout.
1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the page, click Configuration Setting > Server
configuration.

3.

In the list, find the setting that you want to change.

4.

Next to the setting name, click

5.

At the bottom of the page, make the desired changes.

6.

Click Save.

and select Edit.

Server configuration settings
This topic describes the settings on the Server configuration page. To find this page, click
Administration > Administrator tools > Configuration Setting > Server
configuration.
Setting name

Description

MANUALPATIENTMANAG Enables clinicians in facilities that
lack an EMR to admit and
EMENT

Default value
FALSE

discharge patients in the Connex
system.
TRUE: Manual patient
management is enabled.

FALSE: Manual patient
management is disabled.
PASSWORDPOLICY.
ACCTLOCKTIMEOUTMIN

Length of time (in minutes) after a 1440
password lockout due to failed
login attempts that the account will
unlock.

PASSWORDPOLICY.
DEFAULTPASSWORD

Default password that users get
when their accounts are created.

WelchAllyn
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Setting name

Description

Default value

PASSWORDPOLICY.
ENABLED

TRUE: Password policy settings

FALSE

(PASSWORDPOLICY.*) are
enabled.

FALSE: Password policy settings
(PASSWORDPOLICY.*) are
disabled.
PASSWORDPOLICY.
EXPIRATIONINDAYS

Number of days before users are
90
required to change their password.

PASSWORDPOLICY.
HISTORYENTRIES

List of passwords recently used in 3
the system which cannot be reused
when changing a password. The
integer is the number of historic
passwords maintained in the list.

PASSWORDPOLICY.
MAXFAILEDATTEMPTS

Disables a user account after a
specified number of failed login
attempts.

3

PASSWORDPOLICY.
VALIDATIONRULE

Requires a regular expression to
enforce password requirements:
•
Minimum number of total
characters
•
Minimum number of
lowercase characters
•
Minimum number of
uppercase characters
•
Minimum number of numeric
characters
•
Minimum number of special
characters (not alphanumeric)

The default expression defines
these requirements:
•
Minimum number of total
characters: 8
•
Minimum number of
lowercase characters: 1
•
Minimum number of
uppercase characters: 1
•
Minimum number of numeric
characters: 1
•
Minimum number of special
characters: 1
<?xml version="1.0"
encoding="utf-8" ?
><PasswordPolicy><PolicyItem
Key="EightCharReq" Regex="(?=.
{8,})" /><PolicyItem
Key="OneLowerReq" Regex="(?
=.*[a-z])" /><PolicyItem
Key="OneUpperReq" Regex="(?
=.*[A-Z])" /><PolicyItem
Key="OneNumericReq" Regex="(?
=.*[\d])" /><PolicyItem
Key="OneSpecialReq" Regex="(?
=.*[\W])" /></PasswordPolicy>
If you would like this setting
changed, call Welch Allyn
Technical Support.

PASSWORDPOLICY.
WARNINGINDAYS

Specifies when users will be
notified that their passwords will
expire soon. This value is the
number of days before the
password expires.

15
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Setting name

Description

PATIENTMATCHINGRULE Attributes used to help prevent
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Default value
1

duplicate entry of patient
information when patient
information is obtained from an
external or untrusted data source
(e.g., ADT, device, or imported file).

Possible values:
•
1 = MRN only
•
2 = MRN, DOB, Gender
•
3 = MRN, DOB, Gender,
LastName

PATIENTOPENVISIT.
TIMELAPSEINMINUTES

Length of time (in minutes) that the 1440
server looks in the past to find a
closed visit to associate a test to, if
no open visit exists.

PVIDFIELD

Reflects the patient ID used for
barcode wristbands or manually
entered into a vital signs device.
The Connex VM system displays
the patient ID in the client
application and uses it to match
imported vital signs readings to
patient records in the database.

Patient.MRN

Options:
•
Patient.MRN The patient’s
medical record number.
•
Patient.GovernmentNumber The
patient’s government-assigned number
(for example, Social Security number in
the US).
•
Patient.DriverLicenseNumber
The patient’s driver’s license number.
•
Patient.AccountNumber The
patient’s account number.
•
Visit.AccountNumber The
patient’s visit account number.
•
Visit.VisitNumber The
number assigned to the
patient for a particular visit.

SERIALNUMBER

Serial number of Connex VM.
For Welch Allyn use only. Do not
modify.

Seven-digit alphanumeric string
starting with CNX.

“DEFAULTSSOUSER” is the default DEFAULTSSOUSER
SINGLESIGNON.
DEFAULTUSERACCOUNT user used as a template for
Guid = "80B7C697-BE7F-4DF4-9FE4automatically creating user
accounts during single-signon. An
administrator can edit this user
account but not delete it. All users
that authenticate using singlesignon and do not already have a

A52D508D38E4"
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Setting name

Description

Default value

user account will inherit this default
account’s values except for the
user name.

SINGLESIGNON.ENABLED TRUE: Single sign-on is enabled. FALSE
FALSE: Standard sign-on is
enabled.

SINGLESIGNON.LDAPSEA Supports future Active Directory
single-signons.
RCHPATH
SINGLESIGNON.LDAPUSE Supports future Active Directory
single-signons.
RNAMEATTRIBUTE
SYSTEMAUDIT.ENABLED TRUE: Auditing is enabled.
FALSE: Auditing is disabled.
TIMEOUTS.
LOCKSINMINUTES

Length of time (in minutes) that a
concurrency lock lasts.

TRUE

20

Configure settings for Welch Allyn services
From the Server setting page, you can change the connection information and settings for
Welch Allyn services running on the local machine. For changes to take effect, you must restart
the service from the Microsoft Management Console snap-in for Services.
1.

From the machine that you want to configure, open Admin Tools using one of these
methods:
•

From the Windows taskbar, click Start > All Programs > Welch Allyn > Connex >
Welch Allyn Connex Admin Tools.

•

From the client application, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the page, click Configuration Setting > Server
setting.

3.

On the right side of the page, click

next to the desired service.

The settings page for that service appears.
4.

In the Configuration Settings list, find the property that you want to change.

5.

Next to the property name, click

6.

At the bottom of the page, make the desired changes.

7.

Click Save.

and select Edit.

Server settings
The Server setting page displays the Welch Allyn services running on the local machine. You
can access this page from the Windows taskbar (Start > All Programs > Welch Allyn >
Connex > Welch Allyn Connex Admin Tools > Configuration Setting > Server
setting) or through the client application when available (Administration > Administrator
tools > Configuration Setting > Server setting).
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ECS
Use this section to specify the connection information for Welch Allyn Episodic Connectivity
Service.
Property name

Description and default value

HostAddress

IP address, Machine name, or DNS name.

PortNumber

Port used with the above host address to establish the
connection.
For standard installations, the default value is 7732.

WorkstationMode

Only available on a kiosk and Server. This should
never be set to True on the server.
Defines whether the client application can be used to
import and capture data from vital signs devices.
Possible values are true or false.

True: The client application can be used to import
and capture data from vital signs devices. Devices
cannot push data to the machine.
False: The client application cannot be used to

import and capture data from vital signs devices.
Rather, devices can push data to the machine. False
is the default for a kiosk.

MarkDevicePatientAsUnreconciled

When a patient ID coming in from a device to Connex
VM does not exist in the database,
MarkDevicePatientAsUnreconciled defines whether
to mark the records associated with a patient as
reconciled or unreconciled.
Note This switch is only applicable for sites that are
using a PVIDFIELD setting of "Patient.MRN". This
switch does not apply for sites that use other
PVIDFIELD settings.
Possible values are true or false. Default value
is false.
•

•

RejectNonExistentClinician

If a patient ID coming in from a device does not
exist in the database, False indicates that the
associated record will be added to the database
and be reconciled in Connex VM if the patient ID
is an MRN and the patient has demographics
details.
If a patient ID coming in from a device does not
exist in the database, True indicates that the
associated record is marked as unreconciled in
Connex VM.

Defines conditions under which to add a new clinician
to the database if a clinician ID coming in from a
device does not exist in Connex VM.
Default value is False.
•

If a clinician ID coming from a device does not
exist in the database, False indicates that a
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Property name

Description and default value
new clinician record is added in Connex VM
using the clinician information supplied by the
device.
Note In a CVSM, the clinician name values that are
used when creating the clinician are dependent on
the CVSM "Search by clinician ID" configuration
option.
If the CVSM "Search by clinician ID" option is
unchecked and the clinician name is supplied, the
clinician will be created in the database with the first
and last names supplied by the device. If the CVSM
"Search by clinician ID" option is checked or if the
clinician names are not supplied, the clinician will be
created in the database as "New Clinician First Name"
and "New Clinician Last Name".
•
If a clinician ID coming from a device does not
exist in the database, True indicates that the
clinician information provided by the device is
rejected; no new clinician record is added.

Enterprise Gateway
Use this section to specify the connection information for Enterprise Gateway Service.
Property name

Description and default value

HostAddress

IP address, Machine name, or DNS name.

PortNumber

Port used with the above host address to establish the
connection.
For standard installations, the default value is 7732.

Services
Use this section to specify the connection information for Welch Allyn Hosting Service.
Property name

Description and default value

HostAddress

IP address, Machine name, or DNS name.

PortNumber

Port used with the above host address to establish the
connection.
For standard installations, the default value is 7732.

DataBase Name

Name of the SQL database that houses the Connex
VM data.
The default name is WADB.

DataBase Location

Name of the SQL instance used during installation.

Administrator guide

Configuration

Property name

53

Description and default value
If you are using the default database that was
provided during Connex VM installation, and you
selected the defaults during installation, the default
name is .\sqlexpress. Otherwise, contact your
database administrator for this information.

License Admin
Use this section to specify the connection information for the Connex License service.
Property name

Description and default value

HostAddress

IP address, Machine name, or DNS name.

PortNumber

Port used with the above host address to establish the
connection.
For standard installations, the default value is 7732.

Admin Tools
Use this section to specify the connection information for Welch Allyn Connex Admin Tools.
Property name

Description and default values

HostAddress

IP address, Machine name, or DNS name.

Enable Cache

Defines whether the client application can be used
while it is disconnected from the server. Possible
values are true or false.

True: When the workstation is not connected to the
server, users can import and enter data into the
application, which saves the data to its local file
system. When the server is available again, the data
will be uploaded to the server.

False: The application cannot operate until access
to the server is restored.

PortNumber

Port used with the above host address to establish the
connection.
For standard installations, the default value is 7732.

Workstation
Use this section to specify the connection information for the local Welch Allyn Connex
Workstation. The parameters affect only the machine on which you are viewing this information.
Property name

Description and default values

HostAddress

IP address, Machine name, or DNS name.
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Property name

Description and default values

Enable Cache

Defines whether the client application can be used
while it is disconnected from the server. Possible
values are true or false.

True: When the workstation is not connected to the
server, users can import and enter data into the
application, which saves the data to its local file
system. When the server is available again, the data
will be uploaded to the server.

False: The application cannot operate until access
to the server is restored.

PortNumber

Port used with the above host address to establish the
connection.
For standard installations, the default value is 7732.

AllowMultipleInstances

Defines whether multiple instances of the client
application can be launched. Possible values are
true or false.
This setting should only be set to true on a system
hosting a virtual desktop environment such as Citrix
XenApp or Microsoft Remote Desktop Services.

True: Multiple instances of the client application
can be launched. This enables multiple thin clients to
simultaneously access the application over the
network.
False: Multiple instances of the client application
cannot be launched.

Database disk space usage
The DB disk space usage page displays the amount of disk space consumed by Connex, HL7,
and other databases, as well as total available disk space on your system. You can access this
page from the Windows taskbar (Start > All Programs > Welch Allyn > Connex > Welch
Allyn Connex Admin Tools > Configuration Setting > DB disk space usage) or through
the client application when available (Administration > Administrator tools >
Configuration Setting > DB disk space usage).
The following options appear in the table on this page, with DB disk space usage presented in GB:
•

Connex DB

•

HL7 DB

•

Rest Used

•

Free

By clicking on the column headings (Name, Size), you can control the order in which the details
are presented.

Configure Enterprise Gateway Service
The EGS Configuration page enables you to change the settings that control the handling of
HL7 messages into and out of the system.
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1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the page, click EGS > EGS Configuration.
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The Enterprise gateway configuration wizard appears.
3.

Make the desired changes on each screen. Click Next to move from screen to screen.

4.

After you have made all changes, click Finish on the final screen.
A message window appears, which indicates that the EGConfiguration file and Measurement
Conversion XSLT were generated successfully.

EGS configuration settings
This topic describes the options on the EGS Configuration page. To find this page, click
Administration > Administrator tools > EGS > EGS Configuration.

EGS screen 1: Select supported transactions
Use this screen to select the message types that can flow between the server and the hospital
information system (HIS).
Item

Description

Patient inbound transactions

If this is selected, EGS will process inbound HL7 ADT
messages sent from the HIS to the Connex VM server.

Vitals outbound transactions

If this is selected, EGS will generate HL7 ORU
messages from vital signs readings in the Connex VM
server.

EGS screen 2: Configuration for vitals - HL7 generation
Use this screen to control what information is included in the HL7 ORU messages sent from the
server.
Rules
A number of rules control what information is sent from the server. The default is no rules selected.
Item

Description

Send only confirmed vitals tests to HIS

For future use. Do not select this setting.

Visit information required in the output If this is selected, every HL7 message generated
through EGS will contain visit information. If the
HL7

server does not have visit information for the patient,
the HL7 message will contain dummy visit information.

Order information required in the output If this is selected, every HL7 message generated
through EGS will contain the Common Order (ORC)
HL7
and Observation Request (OBR) segments. If the
server does not have this information, the HL7
message will contain dummy information.

Send unreconciled tests to HIS

If this is selected, HL7 messages will be sent for
readings with unreconciled information (i.e., unknown
clinician ID).
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Item

Description

Send unreconciled patient tests to HIS

If this is selected, HL7 messages will be sent for
readings with unreconciled patient information (i.e.,
unknown patient ID).

Connex is the Patient Demographic
Authority

If this is selected, HL7 messages will inherit patient
demographic information from Connex VM.

EGS screen 3: Configuring vitals measurement names between Connex VM
and HIS
Use this screen to configure and map measurement names, modifiers, and units used by the
Connex VM server and the HIS.
Item

Description

Source name

Denotes the measurement names and modifiers used
by the Connex VM server. Modifiers can be
configured in the client application under Tools >
Options > Installations tab > Plugins >
Vital Signs.

Target name

Sets the measurement names and modifiers supplied
in the ORU message sent to the HIS. Click a name to
edit it.

Unit name

Sets the unit of measure supplied in the ORU
message.
To select a unit, click the corresponding
measurement name under Source name to enable
the Unit name menu. Select the unit from the
menu.

EGS screen 4: Enterprise Integration Engine (EIE) Database Configuration
Use this screen to configure the parameters for the Enterprise Integration Engine (EIE) database.
Item

Description and default values

Database name

Name of the SQL database that houses the EIE data.
The default name is WA_EIE_DB.

Database location

Name of the SQL instance where the EIE database
(WA_EIE_DB) resides.
If you are using the default database that was
provided during Connex VM installation, and you
selected the defaults during installation, the default
name is .\SQLExpress. You can also use
machine_name\SQLExpress where
machine_name is the name of the machine where the
WA_EIE_DB resides.
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Description and default values
Otherwise, contact your database administrator for
this information.

User name

Name of the user that has access to the SQL instance
and will be used to create and access the EIE
database.
If you are using the default database that was
provided during Connex VM installation, and you
selected the defaults during installation, the default
name is eieapp.
Otherwise, contact your database administrator for
this information.

Password

If you are using the default database that was
provided during Connex VM installation, and you
selected the defaults during installation, the default
password is eieapp.
Otherwise, contact your database administrator for
this information.

EGS status
This link shows the status of inbound and outbound messages. To find this page, click
Administration > Administrator tools > EGS > View Status.
Item

Description

Last successful inbound message at:

Field shows date and time stamp for message or No
record found.

Last successful outbound message at:

Field shows date and time stamp for message or No
record found.

Refresh

Button updates the screen

Show

The Show drop-down menu provides options for
displaying failed outbound messages. Respond to the
prompt Please select your time scale by
clicking one of the following:
•
Most recent message
•
Today
•
Last [select a number] [select Days or Weeks]
•
All messages
The results window presents a table of failed
messages filtered by the time scale you selected, as
shown below. Navigation buttons
facilitate movement through pages of results.

Sample EGS status screen
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Import/Export
The Import/Export tools support the transfer of settings between test systems and production
servers after initial Connex VM system configuration. A clear understanding of how this function
works is important to avoid untoward results. Take care when using this feature as it does not
replace contents, but merges the contents being imported with what is already there.
To illustrate this point, please review the following scenario:
The source system has three users
Note
User ID

This does not include a complete listing of information – it is for representative
purposes only.
Clinician ID

H0001

LName

FName

User roles

Snead

Sam

Manager

H0002

123456

Smith

John

User

H0003

112233

Frye

Kaylee

Doctor

The target system has two users:
User ID

Clinician ID

LName

FName

User roles

H0001

998877

Snead

Sam

User

H0004

123456

Scagliotti

Allison

User

After an export from the source and import to the target, the result on the target system is as
follows:
User ID

Clinician ID

LName

FName

User roles

Differences

H0001

998877

Snead

Sam

User

This person is now
a User with a
clinician ID.
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User ID

Clinician ID

LName

FName

User roles

Differences

H0002

123456

Smith

John

User

This person was
added.

H0003

112233

Frye

Kaylee

Doctor

This person was
added.

H0004

123456

Scagliotti

Allison

User

This person remains
unchanged.

To find these tools, select Administration > Administrator tools > Import/Export.
The following settings can be exported from and imported into a system:
•

All user parameters including passwords and assigned user roles.

•

All configured roles and privileges.

•

All configured locations.

•

All server configuration parameters.

•

All parameters configured on the Options screen: Location alerts, Machine and User
application settings, and Plug-in settings and modifiers.

•

All Enterprise Gateway Configuration Wizard configured parameters.

Export settings
1.

Click Export Settings, located in the left pane.
The Export Settings window appears.

With this tool, you can export the following settings to a selected location:
•

User accounts settings

•

Locations settings

•

Server configuration settings

•

EGS configuration settings
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2.

Select the settings you want to export, then click Export.

3.

In the Save exported information window, select the destination for the exported settings and
click Save.
The default name of the exported file is WAConfigurationSettings, but you can rename the file.
If another file exists with the same file name, you are prompted to replace it.
If the settings were exported successfully, a confirmation window appears.

4.

Click OK.

Import settings
1.

Click Import Settings in the left pane.
The Import Settings window appears.

2.

Click the Browse... button.
The Select file to import window appears.

3.

Select the settings file you want to import and click Open.
The file name appears in the Select file field.

4.

Click Import.
A list of imported settings appears in the Import Summary window, as shown in this example.
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Disaster recovery
Back up server databases
Back up the Welch Allyn Connex VM database (WADB) and the Welch Allyn Enterprise Integration
Engine database (WA_EIE_DB) on a regular basis by following your facility IT guidelines and
policies for backing up patient data. Welch Allyn recommends a full backup to simplify data
recovery.
You can automate this process by using a commercial database backup utility that can back up a
live MS SQL database.
If your facility does not have a backup procedure, use Microsoft SQL Server Management Studio
to back up the databases.
For more information, see “How to: Back Up a Database (SQL Server Management Studio)”:
•

For SQL Server 2008 Express: http://msdn2.microsoft.com/en-us/library/ms187510.aspx

Note

For customers upgrading from earlier versions of Connex VM with SQL Server 2005,
use the information presented at http://msdn.microsoft.com/en-us/library/
ms187510(SQL.90).aspx to back up your server database.

Back up configuration files
In addition to backing up the two SQL databases, you should also back up a copy of the following
configuration items:
1.
2.
3.

Connex VM Installation DVD. This disk contains the Connex VM Server and Workstation
installation program. Use this backup disk to restore the Connex VM Server and to install/
reinstall the Connex VM Workstation client on a PC.
Connex VM HL7 Interface DVD. This disk contains the Connex VM HL7 Interface
components. Use this backup disk to restore the Connex VM Server with HL7 functionality.
Corepoint License File. This is the license file for the Corepoint Integration Engine
component of the Connex VM HL7 Interface. The Corepoint license file is found in one of the
following directories:
•

C:\Program Files\Corepoint Health\Corepoint Integration Engine

• C:\Program Files (x86)\Corepoint Health\Corepoint Integration Engine
Only one license file will be stored on your system, and it will end with the extension “.lic” as
shown in the examples below:
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4.
5.

NeoBrowse96.lic
NeoIntegrate5920.lic
NeoIntegrate.lic
NeoBrowse.lic
Corepoint Configuration file. This file, along with the XLST files, contains most of the HL7
Interface Configuration. This file has a file extension of “.nix” and will be saved on the local
server after the installation has been completed and the configuration has been finalized.
XSLT files. These files are in one of the following directories:
•

6.
7.

C:\Program Files\ Welch Allyn\Connex VM\EGS\XSLT

• C:\Program Files (x86)\Welch Allyn\Connex VM\EGS\XSLT
If you copied the entire XSLT folder, you would have the customized files for your setup. As
you make changes to the Inbound and Outbound HL7 interface, some of the files in the XSLT
folder will change as well.
The EGConfiguration.xml file, which holds all the EGS Wizard Configuration Settings.
The Connex VM License File.

If you ever need to restore the system, you must reinstall these items along with the two SQL
databases.

Restore server databases
Follow your facility IT guidelines and policies to restore the Welch Allyn Connex VM database
(WADB) and the Welch Allyn Enterprise Integration Engine database (WA_EIE_DB).
If your facility does not have a restore procedure and you use Microsoft SQL Server Management
Studio (SSMS) to back up the databases, use SSMS to restore them. If you have a service
agreement with Welch Allyn, call Technical Support before proceeding.
For more information, see “How to: Restore a Database Backup (SQL Server Management
Studio)”:
•

For SQL Server 2008: http://msdn2.microsoft.com/en-us/library/ms177429.aspx

Note

Changes made to the database since the last backup are not restored.

Deleting Connex VM and EGS log files
The Connex VM system records specific service-related activities in log files. To recover space
these files occupy, use one of the following methods.
•

Delete files individually
1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the screen, click Logs > Application logs.

3.

Under Select folder, select a folder from the drop-down list:
Folder

Description

ECS

Log statements from the Episodic Connectivity
Service provide various information based on your
selection. Options include:
• Vitals test save logs based on Patient IDs
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Description
• Query logsbased on Patient IDs, Clinician IDs, and
Location IDs

FrameworkCach Log statements on the client-side cache used in
e
disconnected mode.
WelchAllyn.Conn Log statements from Client Services that run on the
ex.ClientService server.
s
WelchAllyn.Conn Log statements from the Connex VM workstation
exVM
application.
WelchAllyn.Ente Log statements from the Enterprise Gateway Service
rpriseGateway used to process interface transactions.
WelchAllyn.Servi Log statements from the client side framework that
ces.Entities
communicate with the server.

•

4.

Click Search. Log files appear in the Log file list.

5.

Find the file that you want to delete.

6.

Next to the file name, click

and select Delete.

Delete files using Windows Explorer
CAUTION Use extreme caution. This approach should be
undertaken only by experienced Windows Server Administrators.

Setting the Corepoint purge period
Corepoint log files record transaction activity to and from the HIS system. The software is installed
with the time period of file purging to NEVER. To reduce the buildup of these transaction files, it is
recommended that you establish a purge period. The period is unique to each organization, but
should be no less than 30 days for support, should it be required. To determine the current purge
interval, follow the instructions below. If a change is desired, contact Welch Allyn Technical
Support.
1.

Log into the Corepoint Integration Engine Configuration application. Use the username
‘Manager’ and your unique password.
The following screen and notice appear.
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2.

Select Service > Log Settings.

The following screen, that shows the current settings, appears.
To make a change, theOK button does not need to be accessible. If a change is desired,
contact Welch Allyn Technical Support.
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HL7 connectivity
Corepoint Integration Engine
The Corepoint Integration Engine transfers inbound and outbound data between the Connex VM
HL7 database and the HIS. Through the Corepoint Administration Console (Corepoint Integration
Engine - Administration), you can monitor and manage connectivity and HL7 messages.
Note

When the SQL Server that hosts the Connex VM and HL7 databases is offline or
cannot be reached, stop the Corepoint Integration Engine service via the Corepoint
Administration Console or the Microsoft Management Console snap-in for Services.
For more information on stopping the Corepoint Integration Engine service, refer to
the Corepoint Help file.

Corepoint user profiles
Corepoint provides two user profiles: View Only and Manager. For more information, refer to the
Corepoint Help file.

Privileges
Privilege category

Privilege

View Only

Manager

General
X

Start & Stop Service
View Engine Log
Manage Licenses

X

X
X
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Privilege category

Privilege

View Only

Manager
X

View & Export
Configuration Objects
Connections
X

View Connection Status

X
X

Start & Stop Connections ¹
X

View Alerts

X
X

Resolve Alerts
View Connection Logs

X

X

View Messages

X

X

Save Messages

X

Resend Messages¹

X

Apply to All Connections

X

X

X

X

Operational Perspectives
Apply to All Operational Perspectives
¹ You must resolve the underlying issue before executing the privilege.

User names and passwords
User names and passwords are case-sensitive.
Profile

User name

Password

View Only

View

ViewOnly

Manager

Manager

ManageHL7

Note

The user names and passwords listed here are the defaults for each profile.

HL7 message monitoring and maintenance
The Corepoint application provides information about each message sent between the server and
an HL7 system. You can perform various actions on these messages based on your privileges. The
most basic capability is viewing all messages or applying filters to view only the desired messages.
For more information, see the Corepoint Help.
1.

On the Windows taskbar, click Start > All Programs > Corepoint Health > Corepoint
Integration Engine > Corepoint Integration Engine - Administration. If prompted,
log on, using the credentials listed in “HL7 connectivity.”
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The console screen appears.

2.

Click the appropriate connection.
Note

The descriptions are from the perspective of VM:
•

“Welch_Multi IB” indicates ADT HL7 messages coming from the HIS to Connex
VM.

•

“Welch_Multi OB” indicates Result HL7 message coming from Connex VM to the
HIS.

A window similar to the following appears.

3.

Complete the following tasks on this screen:
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Select the dates you plan to resend the messages.

Note

To select multiple dates, press and hold the Ctrl key
while clicking to select.

Select the desired connection in the Connections box.
Select the desired log type in the Log Types box (typically raw).
Click View Selected Logs.

The Log Files page appears. For example:

4.

(Optional) Filter the messages as desired by using these features:
•

Click the icons on the right side of the screen

•

If you need more filter options, click the Filter arrow below the Log Selection tab.
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For example, searching for an ID of M0001 in the Unparsed Data would require filling out the
Filters window as shown here.

5.

To see the HL7 messages for the returned results with the selected filter criteria, click one of
the messages.
The HL7 message appears at the bottom of the screen.
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6.

Before taking any allowed action (such as resending a message) related to a HL7 message,
make sure that the underlying cause of any issue is resolved.

Auto-installing patches from Microsoft®
Apply software updates in a controlled fashion with direct user interaction. Although Connex
services properly restart, services that Connex services depend upon, such as SQL, may not restart
in a timely manner, preventing Connex services from successfully attaching to them.
After the update completes, reboot the system (preferred), or stop and restart the following
services in the order shown:
Service

Stop order

Start order

Welch Allyn Enterprise Gateway

1

3

Welch Allyn Connex Episodic Connectivity Service

2

2

Welch Allyn Connex Client Services

3

1
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Reconciliation in the Connex VM system
When a reading is imported from a vital signs device, the Connex VM system attempts to match the
reading to a patient record in the Connex VM database.
“Reconciled” means the system successfully matches the reading to a patient record in the
database. The system adds the reading to the record and sends the reading to the HIS.
“Unreconciled” means the system cannot match the reading to a patient record. The system saves
the reading as unreconciled data and does not send it to the HIS. The reading can be viewed or
deleted from the Search page.

* The system creates a new patient record, saves the reading to the record, and sends the record
to the HIS.
** The system creates a new patient record, but saves the record and the reading as unreconciled
data. The record is unusable; it cannot be updated or sent to the HIS.
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Patient ID behavior - default operation
When a Patient ID is entered on a vital signs monitoring device (scanned or typed), the scanned
value is sent to Connex VM with the captured vitals.
Note

If the Search by patient ID option is enabled on the Connex Vitals Sign Monitor
(Connex VSM), upon scanning a Patient ID from the Home screen, the Connex VSM
will query Connex VM for the Patient name information. If the Connex VSM is
configured to display the Patient name information on the Home screen, the
clinician may confirm that the patient ID and patient name match.

By default, Connex VM looks for the entered Patient ID in the Connex VM Patient list and connects
the vitals with the Patient Demographics Information and use the values in the PID segment with
the HL7 ORU message sent to the EMR.
If Connex VM cannot find the entered Patient ID, the vitals set is placed in the Unreconciled data
tab. The Patient ID can be edited to reconcile the vitals data to an existing patient. For additional
information, see the Connex VM directions for use.
Sample Vitals Reading for Unknown Patient Shown on Unreconciled Data
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Alternative setup
Connex VM can be configured to send vitals for unknown Patient IDs to the EMR and allow the
EMR to decide how to handle unreconciled Patient IDs.
The vitals set still appears on the Unreconciled data page, but the vitals are sent to the EMR via
HL7. Because no Patient ID information is known, Connex HL7 sends the entered Patient ID
(received from the vitals signs device) in the following fields of the PID segment: PID-2, PID-3,
PID-18, PID-19, and PID-20. Field PID-5 Patient Name List is blank.
Sample HL7 Message for Unknown Patient ID (entered ID shown underscored and in
boldface)
MSH|^~\&|EIE|WelchAllyn|HIS|WelchAllyn|20101122101839||ORU^R01|2010-11-22 10:18:39|P|2.5
PID||A0002|A0002||||||||^^^^^^L|||||||A0002|A0002|A0002
PV1||U|||||||||||||||||11222010101836146|||||||||||||||||||||||||20101122101836
ORC||WA11222010101836136|65
OBR||WA11222010101836136|65|RC1|||20101122101632|||C0001^Nancy^Nurse^L^^Mrs.
OBX|1|NM|TEMP^Temperature^L|1|97.5|F|||||R|||20101122101629||C0001^Nancy^Nurse^^^Mrs.
OBX|2|ST|TEMPSITE^TEMPERATURE SITE^L|1|Oral||||||R|||20101122101629||
C0001^Nancy^Nurse^^^Mrs.
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Virtual desktop environment
In a virtual desktop environment, the Connex VM client application is installed on a virtual desktop
server and configured to support multiple, simultaneous client sessions. Companies that provide
virtual desktop capabilities include Microsoft and Citrix.

Thin client setup
On each thin client, you must do one or both of the following to enable the client to capture and
transfer data from vital signs devices.
•

Connect vital signs devices via serial cable: Enable COM port forwarding through the
virtual desktop application on the client (for example, Citrix or Microsoft Remote Desktop
Connection).

•

Connect vital signs devices to the client via USB cable: Install Welch Allyn Virtual
Channel Client (VCC) on the client. VCC enables the virtual desktop server to see USBconnected devices.

For more information on enabling COM port forwarding through Citrix or Remote Desktop
Connection, refer to documentation from Citrix or Microsoft.
For more information on VCC, visit welchallyn.com or contact your Welch Allyn sales
representative.
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Connex VM services
Service

Use

Effects on system use

WA Connex Client Services

Facilitates Connex VM client
application access to the server.

If this service is not running, users
would not be able to open the
Connex VM Workstation application.

Both the Connex ECS and EGS
Service are dependent upon the
Connex Client Service running.

WA Connex Episodic
Connectivity Service (ECS)

Receives messages and requests
from the devices and processes them
for use by the Connex VM server. The
ECS is the device connectivity
solution for Welch Allyn devices.

This is the primary Connex Service
that both the Connex ECS and EGS
Service are dependent upon and
should be started before the ECS and
EGS are started.
If this service is not running, the
patient vitals would be on the CVSM.
Unsent vitals could be found on the
Review tab of the CVSM and resent
from there once the service was
restarted.
Patient and Clinician queries by the
CVSM would not be responded to
when the service is down.

WA Enterprise Gateway
Service (EGS)

Facilitates communication between
the Connex VM Database and the
HL7 Database. This service moves
patient and vitals between the two
databases for all inbound ADT
messages and outbound ORU
messages.

If this service is not running,
outbound vitals would remain in the
Connex VM database until the
Service was restarted.
Once the service was running, all
completed vitals would be processed
into the HL7 database for processing
by the outbound interface.

Corepoint Integration Engine

This service is the main HL7 Interface If this service is not running, the
service that processes the inbound outbound ORU messages would not
ADT and outbound ORU messages. be generated. The pending messages
would be held in the HL7 database
and would be sent once the service
was back up.

Corepoint Integration Engine
Assured Availability

Not used with Welch Allyn solution

Not used with Welch Allyn solution
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Service

Use

Effects on system use

Corepoint Integration Engine
Configuration Service

This service provides the Corepoint
Integration Engine Configuration
utility used to modify the interface
configuration and setup.

If this service is not running,
administrators would not be able to
open the Corepoint Integration
Engine Configuration utility.

Corepoint Integration Engine
Monitor Service

This service provides the Corepoint
Integration Engine Administration
utility used to monitor the Interfaces
and view the interface log files.

If this service is not running,
administrators would not be able to
open the Corepoint Integration
Engine Administration utility.

Logs
View, print, and delete audit logs
An audit log is a record of activity in the system, including all events and user transactions.
1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the page, click Logs > Audit log.

3.

Search the audit log by selecting search criteria from the drop-down lists. Multiple search
criteria can be used to narrow down the search results.

4.

Click Search.
Search results appear in the Audit items list.

5.

(Optional) Print the list or delete audit items.
•

Print the list: Click the Print button.

•

Delete audit items: In the Audit items list, click items to select them. Click Delete
selected.

Audit log search criteria
The following tables describe the search criteria drop-down lists on the Audit log page (available
from the menu bar under Administration > Administrator tools > Logs).

Audit type
Option

Description

Add
Update
Delete
Select

Shows records for the selected transaction for record data types of User,
Patient, Location, Test, and Configuration parameters.

Print

Shows all Print transactions.

Login

Shows all Login transactions.

Logout

Shows all Logout transactions.
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Option

Description

SetPassword

Shows all password changes to user accounts.

DeviceConnection

Shows all instances when a device was connected to a Connex VM
workstation or kiosk.

Option

Description

Clinician

Shows changes (add, update, etc.) related to clinicians.

Configuration

Shows changes to global system settings or workstation-specific changes.

Group

Shows changes to general settings for users, locations, and workstations.

Patient

Shows changes made to patient information.

SecurityRole

Shows changes made to roles.

Test

Shows changes related to measurement data.

Visit

Shows changes to visit information.

UserAccount

Shows changes related to user accounts.
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Entity type

View application logs
Application logs are used primarily for Welch Allyn Technical Support.
1.

In the menu bar, click Administration > Administrator tools.

2.

In the navigation bar on the left side of the screen, click Logs > Application logs.

3.

Under Select folder, select a folder from the drop-down list:
•

4.

ECS – Log statements from the Episodic Connectivity Service provide various information
based on your selection. Options include
○

Vitals test save logs based on Patient IDs

○

Query logs based on Patient IDs, Clinician IDs, and Location IDs

•

FrameworkCache – Log statements on the client side cache used in disconnected
mode.

•

WelchAllyn.Connex.ClientServices – Log statements from Client Services that run
on the server.

•

WelchAllyn.ConnexVM – Log statements from the Connex VM workstation
application.

•

WelchAllyn.EnterpriseGateway – Log statements from the HL7 gateway service.

•

WelchAllyn.Services.Entities – Log statements from the client side framework that
communicate with the server.

Click Search. Log files appear in the Log file list.

80 Troubleshooting

Welch Allyn Connex® VM data management system

5.

In the list, find the file that you want to view.

6.

Next to the file name, click

and select View.

The Log Viewer window appears.
7.

(Optional) Apply filters.
•

Next to the word Filters, click Priority and select or clear filters from the drop-down list.

•

Click Category and select or clear filters from the drop-down list.

Troubleshooting services
The system contains several Windows services that control data transfer. If one part of the system
is not communicating with another, the service that controls the connection might be the source of
the problem.
In your troubleshooting procedure, include these tasks:
•

Verify that the appropriate service is running. If the service is not running, start it.

•

When troubleshooting the connection between a workstation and the server, test the service
on the workstation to verify that it can connect to the server.

If you are accustomed to starting and testing Windows services, use the methods you prefer. If you
do not have experience with these tasks, you can use the client application for troubleshooting.
The following sections provide instructions.
To learn more about each service and its purpose, refer to the “Reference” section.

Verify that a service is running
1.

In the menu bar, click Administration > Administrator tools.
If you cannot start the program, open Admin Tools from the Windows taskbar: Start > All
Programs > Welch Allyn > Connex > Welch Allyn Connex Admin Tools.

2.

In the navigation bar on the left side of the page, click Configuration Setting > Server
setting.

3.

Next to the service name, check the status of that service.
A green indicator appears next to services that are running, whereas a red indicator appears
next to services that have not been started or have been stopped. A status message also
appears to the right of the indicator.
Sample status messages:
•

Welch Allyn Connex Episodic Connectivity Service is Stopped

•

Welch Allyn Connex Client Services is Running
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Start a service
1.

In the menu bar, click Administration > Administrator tools.
If you cannot start the program, open Admin Tools from the Windows taskbar: Start > All
Programs > Welch Allyn > Connex > Welch Allyn Connex Admin Tools.

2.

In the navigation bar on the left side of the page, click Configuration Setting > Server
setting.

3.

Next to the service that you want to start, click Restart Service.
When the service starts, the formerly red indicator turns green, and the status message states
that the service is running.

Restart a service
For service settings changes to take effect, the service needs to be restarted. To restart a service
that is running, do not use the Administrator tools restart function in the Connex VM client
application, but instead go to the Microsoft Management Console snap-in for Services.
1.

From the Windows taskbar, click Start > Control Panel > Administrative Tools >
Services.
The Services window appears.

2.

Right-click the appropriate service and select Stop.

3.

Wait 30 seconds.

4.

Right-click the service and select Start.

Test a service
You can use this feature to verify that a service on a workstation can connect to the server.
1.

In the menu bar, click Administration > Administrator tools.
If you cannot start the program, open Admin Tools from the Windows taskbar: Start > All
Programs > Welch Allyn > Connex > Welch Allyn Connex Admin Tools.

2.

In the navigation bar on the left side of the page, click Configuration Setting > Server
setting.

3.

Next to the service name, click Test Service.
The application directs the default web browser to open an HTML page on the server to see
whether the service can connect to the server via the specified IP address and port number.
If the service connects to the server, a page with the title “SessionService Service” appears.
If the connection fails, a page with the title "The page cannot be displayed" appears. This
problem has two possible causes:
•

The service is pointing to the wrong IP address or port.

•

A firewall on the workstation or network is preventing the service from connecting to the
server.

82 Troubleshooting

Welch Allyn Connex® VM data management system

Troubleshooting network problems
Use a protocol analyzer to capture network traffic
A network protocol analyzer can be used to assist in determining if information is flowing between
the Connex VM server and the devices, workstations, and kiosks used within the Connex VM
system. This section is intended for individuals familiar with IP networks and the use of a protocol
analyzer. It is suggested that the selected protocol analyzer is capable of capturing network traffic
and operating at full network interface speed.
The network traffic of particular interest is the DCP traffic (UDP/44435 or UDP/7711). The goal is to
observe that DCP discovery packets are received from the device. The easiest approach is to
suppress all unwanted traffic using the packet filtering capability of your protocol analyzer. The
initial filter setting should limit traffic to and from the device in question by IP address. Other traffic
of interest is traffic from the device to the DHCP server.
As an example, a device sends a UDP broadcast to port 44435 on the network. The DCP application
replies to the device with the IP address and TCP port of the Connex VM server, and subsequent
communications are done via TCP.
Note

This operation might require the configuration of an IP helper address in a routed
network.

Troubleshooting specific problems
Problem: Client application does not acknowledge a connected device.
The client application displays one of two messages in the bottom right corner of the main window.
A device is connected and communicating with the
application.
A device is disconnected or not communicating with
the application.

If you connect a device to the workstation and No device connected persists, follow these
troubleshooting steps.
Possible cause

Corrective action

The application does not recognize the device.

Right-click No device connected and select
Refresh devices. The message changes to
Device connected.

The device is turned off or does not have power.

Turn on the device.
Connect the device to a power source. If the device is
running on batteries, ensure that the batteries have
sufficient charge to operate the device.

The connectivity cable is not attached to the device or Attach the cable to the device and the workstation.
the workstation.
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Possible cause

Corrective action

The connectivity cable is damaged.

Use another cable.

The device has been replaced with another device.

Exit the application, unplug and reattach the cable,
and then restart the application.

The device is not configured properly.

Verify that the device is configured properly to send
data, per the directions for use that came with the
device.

The device driver is corrupt.

Reinstall the driver.

The USB port is damaged.

Plug the device into a different USB port.
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The Welch Allyn Device Connectivity Service (DCS) is Start the service.
not running.

Problem: Workstation is not communicating with the server.
Possible cause

Corrective action

When I open the client application, I get an error
message.

View application logs.

The wireless network connection has been lost.

Move the computer where there is a known network
connection.
Use PING or TRACERT from the Windows Command
Prompt to confirm that the workstation can connect to
the server.

The network is down; a path to the Connex VM Server Check other software for the same difficulty. If other
cannot be found.
applications (for example, a web browser) work,
verify that the Welch Allyn Hosting Service is
reachable through Administrator tools >
Configuration Setting > Server setting >
Test Service. If this is unsuccessful, verify that the
Hosting Service is running on the Connex VM Server
and, if needed, restart the service.
Use a protocol analyzer to analyze network traffic.
The Connex VM Server is down.

Verify that the Connex VM Server is running with all of
the necessary services.
Check the application logs for error conditions.
Verify network connectivity to the Connex VM
Workstation or Kiosk in question using PING or
TRACERT.

The workstation is not connected to the network.

Plug the workstation into the network and verify that
the workstation shows a LINK light for the Connex VM
Workstation or Connex VM Kiosk.
Verify that the workstation has the proper IP settings
(cmd > ipconfig /all).
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Corrective action

The wrong IP address for the Connex VM Server was Use All Programs > Welch Allyn > Connex >
entered into the Connex VM Workstation.
Welch Allyn Connex Admin Tools to verify
the server IP address. Correct as necessary.

Problem: Server did not receive data from a wireless device.
Possible cause

Corrective action

The device is turned off or does not have power.

Turn on the device.
Connect the device to a power source. If the device is
running on batteries, ensure that the batteries have
sufficient charge to operate the device.

The barcode that was scanned was for the wrong Verify that the correct barcodes were used.
clinician or patient.
Verify that the barcodes are assigned properly.
Temperature was taken in Monitoring Mode.

Verify that temperature was not taken in Monitoring
Mode. Temperatures read in Monitoring Mode cannot be
transferred to the server.

The device, wireless radio, null modem
connectors, and barcode scanner are not
configured or cabled properly.

Verify that the device, wireless radio, null modem
connectors, and barcode scanner are configured and
cabled properly.
From any Connex VM workstation, ping the radio from
the Windows Command Prompt to confirm that the radio
can connect to the server.

The device is in a location with a weak signal or no Move the device where there is a known network
signal.
connection.
The Welch Allyn Episodic Connectivity Service
(ECS) is not running.

Start the service.

Device Connection Protocol (DCP) is not running.

Start DCP.

DCP is listening on the wrong port.

Verify that DCP is listening on the correct UDP port:

From the Connex VM server, issue the command
netstat -na from the Windows Command
Prompt.
If the results include port 44435 and/or port 7711, DCP is
correctly configured. If either port 44435 or port 7711 is
not listed, configure the service to listen on the port(s)
not listed.
ECS is listening on the wrong port.

Verify that ECS is listening on TCP port 281. If not,
configure the service to listen on this port.
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Possible cause

Corrective action

DCP is not getting the discovery packets from the
device.

Use a protocol analyzer to analyze network traffic.
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Problem: Service or database is unavailable.
Possible cause

Corrective action

The network is not available.

Verify that the network to the Welch Allyn Hosting
Service is available and that the workstation is
connected to it.
Verify that the network connection between the
Welch Allyn Hosting Service and the database is
available and working.

The server that the services or database is on is shut Verify and, if necessary, reboot the server.
down.
The Welch Allyn Hosting Service is not running.

Reboot the server that the service is running on.
Restart the service using the Microsoft Management
Console snap-in for Services.
Verify that the service is running under the
appropriate credentials.

The database is not running.

Reboot the server that the database is running on.
Restart the SQL Server service using the Microsoft
Management Console snap-in for Services.

The client application is not configured properly.

Verify that the endpoint definitions are set up to the
proper TCP endpoint.
Verify that the "localhost" certificate is installed.

The Welch Allyn Hosting Service is not configured
properly.

Verify that the service is publishing on the right
endpoint addresses.
Verify that the "localhost" certificate is installed.
Verify that the connection string to the database is set
up to talk to the right database.
Verify that the connection string to the database is
using the correct authentication type and security
token.

The database is not configured for remote access.

Make sure that the SQL Server Browser service is
running on the server with the database.
Verify that the database is configured to communicate
using the TCP/IP communication protocol.
Check the properties of the SQL Server instance and
make sure that instance is configured to allow remote
connections.
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Problem: Connex server is not communicating with the HIS.
The following email alerts notify users (Operator, Supervisor and Administrator) of communication
failures at configurable time intervals. Mail settings are configured by Welch Allyn; please contact
Welch Allyn technical support for changes. Refer to Corepoint help for configuration details.
Contact your technical support representative for more information.
Message

Diagnostic action

Stopped

The Corepoint Integration Engine connection has
stopped for too long.

Not Connected

There is no connection to the trading partner, an
external system or application to whom you are
sending HL7 messages or from whom you are
receiving HL7 messages. You need to establish a
connection between your system and the trading
partner system, typically using TCP/IP.

Idle

No messages are being received or sent.

Send Fail

Corepoint Integration Engine was unable to deliver a
message. Applicable for sender connections only.

Problem: Data is locked.
Possible cause

Corrective action

Someone else is editing or attempting to delete the
same data.

Retry later, or use the Release Locks page to
determine who is editing the data and contact that
person.

When someone else was editing or attempting to
delete the same data, the application "crashed."
When someone else was editing or attempting to
delete the same data, the database or services
became unavailable.

Retry later, or manually release the lock from the

Release Locks page.

Manually release the lock from the Release Locks
page.

Problem: I cannot log on to a Citrix server from a Citrix ICA client.
When you try to log on, an error message appears.
Possible cause

Corrective action

A vital signs device is connected to the Citrix ICA
client via USB cable.

Unplug the device from the client, then log on to the
Citrix server. Reconnect the device.
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Problem: Customizations to modifiers do not appear in the Capture Vital
Signs window.
Possible cause

Corrective action

Customizations were made at the MACHINES
level, but the workstation is not listed in the
MACHINES list.

Log on to the workstation with the ADMIN account.
This action adds the workstation to the
MACHINES list. Verify that the customizations
appear in the Capture Vital Signs window.

Problem: Corepoint Administration Console displays errored messages.
Possible cause

Corrective action

The SQL Server that hosts the Connex VM and HL7
databases is offline or cannot be reached.

Verify that SQL Server is running.
Verify network connectivity to SQL Server.

Note

While SQL Server is unavailable, stop
the Corepoint Integration Engine
service via the Corepoint
Administration Console or the
Microsoft Management Console
snap-in for Services.

Problem: The Spot LXi fails to communicate
Symptom

Possible solutions

The Spot LXi does not communicate via wireless

Check the following:
•
Confirm that the Spot LXi radio is attached to the
network and is assigned an IP address by the
Wireless Access Point.
•
Verify that you can ping the Spot LXi radio
module’s IP address when it tries to send vitals.
•
Confirm that the “Welch Allyn Device
Connectivity Service” is running on the server.
•
Confirm that DCP requests from the device are
getting to the server by checking the DCP.log file.
A successful message looks similar to this:
Format:

“DateTTimeIPAddressUDPPort
[n]: Request[0]”
Example: “2009-11-04T01:25:15

192.168.1.12 44436 [3]:
Request[0]”
Where:

Date The server’s current date.
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Possible solutions
Time The server’s current time.
IPAddress The Spot LXi radio module’s IP
address.

UDPPort The port that this DCP request
packet routes through: 44436 or 44437.
If there are no entries in the DCP.log file, make sure
that the DCP request packets (UDP Port 44435 and
44436) properly route between the wireless network
and the Connex VM server.
The Spot LXi does not communicate when the
Connex VM workstation and the Radio Configuration
utility run on the same machine

The Connex VM workstation and the Spot LXi Radio
Configuration utility use different USB drivers when
connecting to the Spot LXi unit. This is an issue only
when you want to run the Connex VM workstation and
the Radio Configuration utility on the same PC.
The Radio Configuration utility includes configuration
instructions. If you encounter issues when
configuring the utility and testing the USB 0 port,
check which driver is currently associated with the
Spot LXi as described in “Verify the driver associated
with the Welch Allyn Spot Vital SignsLXi.”

Problem: The CVSM fails to communicate
Symptom

Possible solutions

The CVSM does not communicate via wireless

Check the following:
•
Confirm that the CVSM Radio is attached to the
network and is assigned an IP address by the
Wireless Access Point.
•
Confirm that the Welch Allyn Episodic
Connectivity Service is running on the
Connex VM Server. Determine the method used
to get the Connex VM Server address:
○ Hard set (preferred)
1.

Select Settings > Advanced tab

(top).
2.

Enter code 6345.

3.

Select Network tab (bottom) >
Server (top).

4.

○

Click the TEST button on the bottom
right corner.
Dynamically acquired
1.

Select Settings > Advanced tab

(top)
2.

Enter code 6345.

3.

Select the Network tab (bottom).
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Possible solutions
4.

Enter the server’s IP address.

5.

Click the TEST button on the bottom
right corner.
If the CVSM must be configured to
dynamically acquire the server address and
the previous TEST was successful, confirm
that DCP requests from the device are
getting to the DCP Server by checking the
DCP Log file.
A successful message looks similar to this:
Format:

“DateTimeIPAddressUDPPort
[n]: Request[0]”
Where:
Date is the server’s current date.
Time is the server’s current time.
IPAddress is the Spot LXI Radio module’s
IP address.
UDPPort is the port that this DCP request
packet routes through 7711.
If there are no entries in the DCP.log file,
make sure that the DCP request packets
(UDP Port 7711) properly route between the
wireless network and the Connex VM
server.

The CVSM does not communicate when the
The Connex VM Workstation and the CVSM Radio
Connex VM Workstation and the Radio Configuration Configuration utility use different USB drivers when
utility run on the same machine
connecting to the CVSM unit. This is an issue only
when you want to run the Connex VM Workstation
and the Radio Configuration utility on the same PC.
This is not recommended.
The CVSM Radio Configuration utility includes
configuration instructions. If you encounter issues
when configuring the utility and testing the USB 0
port, check which driver is currently associated with
the CVSM as described in “Verify the driver
associated with the Welch Allyn CVSM” in
“Troubleshooting.”

Date/Time synchronization between Connex VM and
CVSM
Dates and times on the Connex VM server and CVSM need to be synchronized. Programming on
both the server and the monitor enable this to happen automatically. In addition to a direct Ethernet
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or Wireless connection to the Server, this feature is also available via a USB connection to a Kiosk
(but not a USB connection to a Workstation).
The Connex VM server is currently set up to adjust automatically for Daylight Saving Time (DST).
Connex Vital Signs Monitors that are set up for the correct time zone, such as (UTC-05:00) Eastern
Time (US & Canada), and have selected Automatically adjust clock for daylight savings
time, reported by host, will get the synchronized time from the Connex VMserver.
Time sync requests are sent from the CVSM as follows:
1.
2.
3.

When the monitor is powered on, it sends a time sync request every 5 minutes until the server
responds.
After receiving the initial time sync response, the monitor sends out a request at 2:05 AM
every day.
If the server does not respond to a daily time sync request, the monitor resends the request at
5-minute intervals until the server responds.

Note

If the time changes on the server after the monitor synched, the monitor takes up to
24 hours to adjust its time. To update the time on the monitor immediately after a
DST change and keep the CVSM in sync with the Connex VM server, simply cycle
power. No other adjustment is required.
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Symptoms and solutions
Symptom

Possible solutions

Spot LXi does not communicate via wireless

Check the following:
•
Confirm that the Spot LXi Radio is attached to the
network and is assigned an IP address by the
Wireless Access Point.
•
Verify that you can ping the Spot LXi Radio
Module’s IP address when it tries to send the
Vitals.
•
Confirm that the “Welch Allyn Device
Connectivity Service” is running on the Server.
•
Confirm that DCP requests from the device are
getting to the server by checking the “DCP.log”
file. A successful message looks similar to this:
Format:

“DateTimeIPAddressUDPPort
[n]: Request[0]”
Example: “2009-11-04T01:25:15

192.168.1.12 44436 [3]:
Request[0]”
Where:

Date The server’s current date.
Time The server’s current time.
IPAddress The Spot LXI Radio module’s IP
address.

UDPPort The port that this DCP request
packet routes through: 44436 or 44437.
If there are no entries in the DCP.log file, make sure
that the DCP request packets (UDP Port 44435 and
44436) properly route between the wireless network
and the Connex Server.
The Spot LXi does not communicate when the Connex The Connex VM Workstation and the LXi Radio
Workstation and the Radio Configuration Utility run on Configuration utility use different USB Drivers when
the same machine
connecting to the LXi unit. This is an issue only when
you want to run the Connex Workstation and the
Radio Configuration Utility on the same PC.
The LXi Radio Configuration utility includes
configuration instructions. If you encounter issues
when configuring the utility and testing the USB 0
port, check which driver is currently associated with
the “Welch Allyn Spot Vital Signs LXI,” as described
in “Verify the driver associated with the Welch
AllynSpot Vital Signs LXi.”
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Verify device drivers
The Connex VM Workstation, Spot LXi Repair Tool, and Spot LXi Radio Configuration use different
USB drivers to connect to the Spot Vital Signs LXi. This can become an issue, but only when you try
to run the Connex VM Workstation and the Radio Configuration Utility on the same PC. This
practice is not recommended.
If these items are installed on or need to be installed on the same computer, install the Spot LXi
Repair Tool or Spot LXi Radio Configuration Utility first. After these service utilities are installed,
you can install the Connex VM Workstation. The installation of the Connex VM workstation
software replaces, but does not remove, the driver used by the repair utilities. You can then use the
Windows Device Manager to switch between drivers. To verify which driver is current, follow the
steps below.
1.

From the Windows task bar, select Start > Run and enter devmgmt.msc.
The Windows device manager appears.

2.

Scroll to Welch Allyn USB Devices and click to expand.
Available Welch Allyn device drivers appear.

3.

Verify the drivers on your system:
Driver

Description

Welch Allyn Spot Vital This is the USB driver for the LXi Repair Tool and Radio
Signs LXi – Beta
Configuration Tool. This driver does not work with
Connex VM.
Welch Allyn Spot Vital This is the USB driver for Connex VM. It is also used by
Signs LXi
Connex CSK.

If the correct drivers are installed, you may have a different issue.
4.

Click Welch Allyn Spot Vitals LXi, and navigate to the Driver tab.
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Verify that you are using the current driver version.
USB driver

Current version

Date

LXi Radio Configuration Utility
(Welch Allyn Spot Vital Signs
LXi – Beta) [wapsusb.sys]

1.0.2.13

6/10/2005

Connex VM Workstation
(Welch Allyn Spot Vital Signs
LXi)

1.8.0.0

7/27/2010
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Changing the active driver
Loading software in the correct order enables the Connex VM client to gather information from an
LXi. To revert the computer to use the one or both the service tools (Welch Allyn Spot Vital Signs
LXi —Beta), perform the following steps:
1.

Open the windows Device Manager by selecting Start > Run, and then entering
devmgmt.msc.
The Windows device manager appears.

2.

Expand the Welch Allyn USB Devices line, right-click the listed device, and click Update
Driver.
The Hardware Update Wizard appears.

3.

Select No, not this time and click Next.
The Windows update screen appears.

4.

Select Install from a list or specific location and click Next.
The Install location screen appears.
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Select Don’t search. I will choose the driver to install. and click Next.
The Search and installation options screen appears.

6.

The wizard prompts you to select which device driver you want to install for this hardware.
•

For the driver used by Connex VM, choose Welch Allyn Spot Vital Signs LXi and
click Next.

•

For the driver used by the repair and radio configuration software, choose Welch Allyn
Spot Vital Signs LXi – Beta and click Next.
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If a success message appears, run the Radio Configuration Utility steps again. If an error
message appears, continue to the next step.
7.

The driver is installed and the Completing the Hardware Update Wizard screen appears.

8.

Click Finish to complete the process.
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Welch Allyn services
The following tables describe the services that are installed as part of the system.

Welch Allyn Connex
Service name

Description

Runs on

DCP Daemon

Provides the Device Connection Protocol for Server
Welch Allyn wireless vital signs devices.
If this service is not running, the devices
cannot connect to the server and send vital
signs data.

Welch Allyn Connex Client Services Provides the connectivity for workstations.

Server

If this service is not running, the workstations
cannot connect to the server.
Welch Allyn Episodic Connectivity
Service

Enables vital signs devices to send data to
the server.

Server and workstation

If this service is not running, both wired and
wireless devices cannot connect to the
server. This service depends on the
Welch Allyn Connex Client Services.
Welch Allyn Enterprise Gateway
Service

Processes patient data and passes data
between the Corepoint Integration Engine
and the Connex VM database.

Server

If this service is not running, HL7 messages
to and from the hospital information system
are not processed.

Welch Allyn PartnerConnect
Service name

Description

Runs on

Axeda Desktop Server

Provides secure remote service and support Server and workstation
delivery used by PartnerConnect.
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Service name

Description

Runs on

WelchAllynRSDSGateway

Provides real-time communication and data Server and workstation
collection for remote software and hardware
resource monitoring.

Corepoint HL7
Service name

Description

Runs on

Corepoint Integration Engine

Processes inbound and outbound HL7
messages between the server and the
hospital information system.

Server

If this service is not running, HL7 messages
to and from the hospital information system
are not processed.
Corepoint Integration Engine
Assured Availability

High availability service for the Corepoint
Integration Engine.

Server

Corepoint Integration Engine
Configuration Service

Manages configuration objects used by the
Corepoint Integration Engine

Server

Corepoint Integration Engine
Monitor Service

Provides web-based monitoring and control
of the Corepoint Integration Engine.

Server

Starting, restarting, and stopping a service
Anytime the EGS Configuration settings change, the service programs involving EGS and Corepoint
Integration Engine must be restarted.
1.

Close all windows.

2.

Open the Windows Services using one of the following:
•

Start > Run > services.msc.

•

Control Panel > Administrative Tools > Services.

3.

Start the Welch Allyn Connex Client Services Service, if it’s not running.

4.

Restart these services by click right-clicking each entry and selecting Start, Restart, or
Stop, as needed.
•

Welch Allyn Enterprise Gateway Service
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•

Corepoint Services
○

Corepoint Integration Engine

○

Corepoint Integration Engine Assured Availability

○

Corepoint Integration Engine Configuration Service

○

Corepoint Integration Engine Monitor Service
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TCP/UDP ports used
The installation program assigns ports to system applications.
The following tables list the port assignments. After installation, you can use this information to
configure the firewalls, virus software, and router access lists for your facility.
The installation program configures the default Microsoft Windows firewall automatically if the
firewall is running at the time of installation.
Note

The ports are configurable (if needed), but must be matched in both the service’s
and workstation’s configuration files.

Note

To upgrade your system or activate licensable features any time after initial
installation, you must reopen the ports that allow Welch Allyn access to your
system.

Welch Allyn Connex
Application

Port number

Protocol

DCP Daemon

44435

UDP

DCP Daemon

7711

UDP

Welch Allyn Episodic Connectivity Service

281

TCP
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Application

Port number

Protocol

Welch Allyn Connex Client Services

8732

TCP

Welch Allyn Hosting Web Service (for testing from the workstation)

8731

HTTP (TCP)

Application

Port number

Protocol

AxedaDesktopServer

5920

TCP

AxedaDesktopServer

5920

UDP

WelchAllynRSDSGateway

3011

TCP

WelchAllynRSDSGateway

3030

TCP

Welch Allyn PartnerConnect - External Connection

443

HTTPS (TCP)

Application

Port number

Protocol

Inbound ADT HL7 Interface Port

Port is defined at TCP
system installation

Outbound HLT Interface Port

Port is defined at TCP
system installation

Welch Allyn PartnerConnect

Corepoint HL7

Medical device connectivity requirements
To communicate with the server, supported devices require the hardware and software listed in
this table. The table also provides guidance on device configuration.

Device

Recommended
minimum
Additional
software
Connectivity accessory
Workflow revision
kits
kits
Configuration

VSM 300 (5300) Mobile
computer

1.2

5300-170

See Note 1

No configuration on
the device is
required to work
with the serial
connection.

2.18

4200-170

See Note 1

No configuration on
the device is
required to work
with the serial

Monitoring
Triage
Spot Vital Signs Mobile
computer
Triage
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Device

Recommended
minimum
Additional
software
Connectivity accessory
Workflow revision
kits
kits
Configuration
(infrared)
connection.

Spot Vital Signs Batch upload 6.0
LXi (wired)
Mobile
computer

4500-925

4500-915

Triage

No configuration on
the device is
required to work
with the USB cable.
For batch spotcheck vitals and
push from device/
auto reconcile
batch, the device
should be
configured for
patient and
clinician
identification.
For push from
device/auto
reconcile batch,
the Information
System setting in
the Configuration
Menu should be
turned on.

Spot Vital Signs Wireless
LXi (wireless)

6.0

4500-922
(802.11a/b/g)

4500-926 or
See 4500-921, DFU,
4500-927 (See Spot LXi b Radio or
Note 2)
4500-923, DFU, Spot
4500-920
(802.11b), US and 4500-906, Spot LXi a/b/g Radio.
Canada only
LXi Radio
See DIR 80012309
Config CD
Version D for radio
4500-907, Spot configuration
LXi Firmware option.
Upgrade CD
4500-915

VSM 6300

One per bed All
Batch upload
Mobile
computer
Monitoring
Triage

4500-925
660-0321-00,
660-0320-00, or
660-0138-00 (see
Note 3)

6000-915 or
6000-915HS
(see Note 4)

See DIR 80012310
Version D for Spot
LXi firmware
upgrade procedure.
Only wired
communications
are available for
this model.
The device should
be configured for
patient and
clinician
identification.
Initial configuration
for Ethernet is done
on the device. The
Welch Allyn
Service Tool
(103521) is used to
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Device

Recommended
minimum
Additional
software
Connectivity accessory
Workflow revision
kits
kits
Configuration
complete the
configuration.
See the VSM 6000
directions for use
(103501) for Connex
VM specific
configuration
requirements for
desired
workflow(s).

VSM 6400

Same as the
VSM 6300

All

Wireless with
radio upgrade
(see VSM
6500 )

4500-925

6000-915 or
6000-915HS
660-0321-00,
660-0320-00, or (see Note 4)
660-0138-00 (see
Note 3)

The device should
be configured for
patient and
clinician
identification.

6000-920 (see
Note 5)

Initial configuration
for Ethernet is done
on the device. The
Welch Allyn
Service Tool
(103521) is used to
complete the
configuration.
See the VSM 6000
directions for use
(103501) for Connex
VM specific
configuration
requirements for
desired
workflow(s).

VSM 6500

Same as the
VSM 6300
Wireless

All

4500-925
660-0321-00,
660-0320-00, or
660-0138-00 (see
Note 3)

6000-915 or
6000-915HS
(see Note 4)

The device should
be configured for
patient and
clinician
identification.
Initial configuration
for Ethernet and
wireless is done on
the device. The
Welch Allyn
Service Tool
(103521) is used to
complete the
configuration.
See the VSM 6000
directions for use
(103501) for Connex
VM specific
configuration
requirements for
desired
workflow(s).
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Device
ProBP 3400

Recommended
minimum
Additional
software
Connectivity accessory
Workflow revision
kits
kits
Configuration
Mobile
computer
Triage

1.3

N/A

N/A

No configuration on
the device is
required to work
with the USB cable.

For instructions on how to check the firmware version on a device, refer to the directions for use
that came with the device or visit our product catalog at welchallyn.com.
Note 1: For PCs with a USB port and no DB-9 serial ports, a Keyspan DB-9 to USB adapter may be
required (Welch Allyn PN: PC-USB-SER).
Note 2: To configure the 4500-920 (IT, WIRELESS RADIO, SPOT ULTRA) and 4500-922 (KIT, 802.11
A/B/G RADIO, SPOT LXI) radio options, either 4500-926 (CABLE FOR WIRED CONN, KEYSPAN; for
PC with USB and no DB-9 serial port) or 4500-927 (USB/SERIAL CABLE KIT FOR SPOT LXI; for PC
with DB-9 serial port) is required.
Note 3: The different connectivity kits provide different capabilities. 4500-9115 is a USB cable for
wired connectivity via USB interface. Part numbers 660-0321-00 (Patch cable, 50'), 660-0320-00
(Patch cable, 100'), and 660-0138-00 (Patch cable, 5') are for Ethernet connectivity.
Note 4: Additional accessories are barcode scanners. 6000-915 includes an 2D barcode scanner,
mounting bracket, license, and hardware. 6000-915HS includes an HS-1M 2D barcode scanner,
coiled USB cable, and license.
Note 5: To upgrade this device for wireless communication, a 6000-920 Internal 802.11 a/b/g
wireless radio kit is required.

